10449 questions

12453 answers

19379 comments

21869 members

+1 vote
169 views 5 comments
by
I need to add a private moon to my zerotier configuration.

Here what i did that didn't work.

created directory /var/lib/zerotier-one/moon.d

placed file xxxxxxx.moon in created directory

restart service but moon is still seen as leaf and my created directory and file in it disapperead.

Any help greatly appreciated.

1 Answer

0 votes
by
Hello,

Regarding the issue, you are having could you send me more information about what you are implementing. Would it be possible to share with me a copy of the said moon file you are having you can share it via PM and a copy of the troubleshoot file of the RUT240 would be a great help also.

Thanks,

Regards,
Mellow
by
I have a file but can't share it. It is the moon we use in production. Quite simply on zerotier to add a moon you have to place that specified file in /var/lib/zerotier-one/moons.d after having created directory moons.d.

If i do the same on RUT240 the directory moons.d is erased on zerotier service restart and it doesn't work. I guess you didn't test anything on zerotier packge.

Maybe if you could update what is now an ancient version (package is 1.1.4, current is 1.6.5) a lot of probs would disappear.
by
I guess you don't care about answering.............

thanks
by
Hello,

Sorry for the late reply. The zero tier package will to 1.6.5 in the next upcoming RUTOS firmware for the exact date when it will be released it will be around this winter but it may change depends on the testing results.

Regards,

Mellow
by
Wouldn't be easier to just release an updated package? Or maybe give instructions to make it ourself?

By the time you will release 1.6.5, next winter, it'll be obsolete again. Everything is becoming obsolete if you don't have enough people to keep things up to date. Just make openwrt packages compatible and just get done with your chronic lateness.
by
Hello,

Sorry for a little bit of correction Zerotier package will be 1.4.5 in the next RutOS version release, not 1.6.5.

As mentioned the current OpenWRT package that RUT240 is supporting now is not supported by the 1.4.5 package of zero tiers. In the next firmware release, it will be compatible with the 1.4.5 zero tier package. So kindly be patient with this.

Thank you and have a nice day!

Regards,
Mellow