11399 questions

13582 answers

21280 comments

31963 members

0 votes
215 views 1 comments
by

Dear Team

I am testing RUT240 with Thingsborad platform, I've found that when router is sending Int 32 Byte data, it is sent smoothly but when I try to send Ascii data, thingboard server does not recieved it.

I found that on Int32Byte data, its not putting "" in the data so the JSON sting is as follows:

[
  {
    "ID": "1",
    "TS": "1626269900",
    "ST": "2",
    "VR": "6650"
  }
]
But when sending ASCII, Its putting "" with the string and that might be the issues, see the string below which RUT240 is sending:


[{"ID":"1", "TS":"1626269722","ST":"8","VR":""Teltonika-RUT240.com""}]
Kindly let me know the solution.

1 Answer

0 votes
by
Hello,

It seems that the extra quotation marks are indeed what limits Thingsboard from processing the data. The most basic solution for this is taking off the quotation marks in your Modbus data to server configuration, so the full data sender configuration JSON format would be as follows:

{"ID":"%i", "TS":"%t","ST":"%s","VR":%a}

If you must have quotation marks in your sent data, then using singular quotation marks also works:

{"ID":"%i", "TS":"%t","ST":"%s","VR":'%a'}
Best answer
by
Dear Aurimas

Thanks for the details, i tried it already and it worked, thanks for your valuable feedback,