8317 questions

9780 answers

15562 comments

13905 members

0 votes
49 views 2 comments
by
Hello,

My RUTX12 is now in a foreign country (Hungary) and the SIM's are roaming. At Status -> Network -> Mobile the operator state is "registered (roaming)" but at Operator I get the home network name (TELEKOM.RO).

The "Events Log" shows this entry: "2021-08-09 05:43:22 | Network Operator | Connected to TELEKOM.RO operator (secondary modem)"; The same operator name again (TELEKOM.RO)

Unfortunately TELEKOM.RO is the name of my home network: Telekom Romania. The router is clearly in Hungary right now, and the modem status clearly says it's Roaming.

Can I somehow get the *true* name of the local (Hungarian) operator my modem is actually connected to?

Thank you,
Cosmin from Romania
by
I somehow got the name of the actual operator using the following CLI commands:

qmicli -d /dev/cdc-wdm0 --nas-get-system-info
qmicli -d /dev/cdc-wdm1 --nas-get-system-info

From the respective otput of each I can tell my router is connected to:

cdc-wdm0 -> MCC=216, MNC=01
cdc-wdm1 -> MCC=216, MNC=30

Using the table here: https://www.mcc-mnc.com/ I can translate the MCC - MNC pair to an actual operator name:

MCC=216, MNC=01 -> Hungary, Pannon/Telenor
MCC=216, MNC=30 -> Hungary, T-mobile/Magyar

Now please tell me there's an obvious and simple way to get the current operator name within WebUI!

1 Answer

0 votes
by
Hi,

The operator name should show up correctly if it shows normally when in the scan page.

Could you try these options:

1. Clear the cache and history of your browser that you're using.

2. Try resetting your router to default factory settings.

3. Try putting the SIM card into another router and check if it finds the correct operator.

4. Also, try disabling the roaming and see if then maybe it connects to something different.

EB.
by
Hello,

1: Did a clear cache and hard reload: nothing changes.

2: The router is in Hungary, I'm home in Romania, I'm connected to the router via RMS. Factory-resetting is not possible at the moment. I'll do it once the router is back home in Romania, but then I don't know when the router will be out of the country to check if the problem is resolved or not. To be honest I'd rather not do this: the router is essentially new, we've got it for less then one week. Starting from the factory firmware we did a firmware upgrade then we configured the router. I will not reconfigure the router again unless I'm 100% certain it would fix the issue.

3: I had the SIM card in a different router before (a Huwaei router) and it always showed the correct Operator name.

4: The SIM's home network is not available in Hungary. If I disable roaming then the SIM would not connect to anything.

Here are some screenshots. I'm having trouble attaching them as proper images to this comment so I'll post the links:

A) Status / Mobile / Secondary MODEM: shows the operator name as "TELEKOM.RO" https://www.dropbox.com/s/ypwsld1rc7iv635/2021-08-11%2015_52_11-Teltonika-RUTX12.com.png?dl=0

B) The CLI command shows I'm connected to operator 21630 (MCC=216, MNC=30) https://www.dropbox.com/s/v828za0i9vxlp05/2021-08-11%2015_57_29-Remote%20management%20system.png?dl=0

C) Here's the list of operators. When going to Network -> Mobile -> Network Operators I was already connected to the "21630". The UI shows this, the list of operators shows the correct name, but then it manages to call it "TELEKOM.RO". I've marked some areas in the picture: https://www.dropbox.com/s/wzung2nn0iw7eqb/2021-08-11%2015_19_10-Slack%20_%20_%20Adi%20Prund%20_%20Adi-Com%20SOFT.png?dl=0