8318 questions

9781 answers

15562 comments

13905 members

0 votes
2,472 views 5 comments
by
With the RUT955 and a wifi AP, wifi client devices cannot access services on LAN clients on the same router.  .e.g 10.66.99.137 on wifi cannot access a file share on LAN client 10.66.99.101.  If I use the same PC with a LAN connection it works.  Wifi clients can access the router at 10.66.99.1 but apparently no other devices.  Netmask is correct on clients as 255.255.255.0 and gateway is set to 10.66.99.1 in all cases.

Any clues?
by
Interestingly:

LAN devices can talk to LAN devices

Wifi devices can talk to Wifi devices

LAN devices can talk to Wifi devices

Wifi devices cannot talk to LAN devices (simply get Destination Host unreachable)

Sort of sounds like a firewall rule, but I can't find one that relates to that problem.
by
And the latest, this appears to be a problem with ARP requests (WHOHAS).

If I ping the wifi client from a LAN client, the entry appears in the ARP table and I can then connect from wifi to the LAN client.  Can't find any form of ARP filtering in the GUI menus, so time to hunt around in the CLI space :(
by
arptables is not installed

ebtables is installed but is set to default accept

nftables is not installed

iptables does not deal with ARP.

Ummm!

3 Answers

0 votes
by

Wireless client isolation/separation?

https://wiki.teltonika.lt/view/Wireless

by
Nope, client separation is off. Problem is wifi clients cannot access LAN services.
0 votes
by
Hello,

This is the function that you're looking for: https://wiki.teltonika.lt/view/Relayd

By default the network configuration is working as intended in your description, but you need to bridge Wireless and LAN interface, thus relayd function will help you with it.
by

I don't think relayd will help here.  The LAN and wifi clients are on the same RUT955 router.  Looking at the IP links:



root@Teltonika-RUT955:~# ip link show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP mode DEFAULT group default qlen 1000

link/ether 00:1e:42:19:d7:53 brd ff:ff:ff:ff:ff:ff

3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000

link/ether 00:1e:42:19:d7:54 brd ff:ff:ff:ff:ff:ff

4: ip6tnl0@NONE: <NOARP> mtu 1452 qdisc noop state DOWN mode DEFAULT group default

link/tunnel6 :: brd ::

5: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 32

link/ether b6:5a:79:79:9b:cb brd ff:ff:ff:ff:ff:ff

6: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 32

link/ether 22:d5:c6:32:f3:83 brd ff:ff:ff:ff:ff:ff

7: gre0@NONE: <NOARP> mtu 1476 qdisc noop state DOWN mode DEFAULT group default

link/gre 0.0.0.0 brd 0.0.0.0

8: gretap0@NONE: <BROADCAST,MULTICAST> mtu 1462 qdisc noop state DOWN mode DEFAULT group default qlen 1000

link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

10: wwan0: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000

link/ether 82:69:84:90:35:3b brd ff:ff:ff:ff:ff:ff

91: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default

link/ether 00:1e:42:19:d7:53 brd ff:ff:ff:ff:ff:ff

125: tun_c_Emizon: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 100

link/none

126: tun_c_Torguard: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 100

link/none

141: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP mode DEFAULT group default qlen 1000

link/ether 00:1e:42:19:d7:55 brd ff:ff:ff:ff:ff:ff

Both wlan0 and eth0 are connected to the br-lan bridge, so it should work.  But it doesn't.

0 votes
by

Hi,

By default such scenario should work in router. So try to reinstall router firmware (DO NOT keep old settings when flashing!)  and then check with default settings your case: connect to router one PC via LAN and another one via WiFi and check if they can reach each other.