8323 questions

9785 answers

15569 comments

13914 members

0 votes
39 views 1 comments
by

Hey!

I am trying to use the RMS API, but I am getting a exception callstack from the server on all endpoints that I am trying.

Example:

curl "https://rms.teltonika-networks.com/api/companies" -H "Authorization: Bearer [omitted]"
<br />
<b>Fatal error</b>:  Uncaught ErrorException: Undefined property: stdClass::$exp in /var/www/rms_api/app/Http/ApiGuard.php:204
Stack trace:
#0 /var/www/rms_api/app/Http/ApiGuard.php(204): Laravel\Lumen\Application-&gt;Laravel\Lumen\Concerns\{closure}(8, 'Undefined prope...', '/var/www/rms_ap...', 204, Array)
#1 /var/www/rms_api/app/Http/ApiGuard.php(182): App\Http\ApiGuard-&gt;mutateUserInformation(Object(stdClass))
#2 /var/www/rms_api/app/Http/ApiGuard.php(111): App\Http\ApiGuard-&gt;resolveUser(Object(stdClass))
#3 /var/www/rms_api/vendor/illuminate/auth/AuthManager.php(294): App\Http\ApiGuard-&gt;user()
#4 /var/www/rms_api/app/Providers/AuthServiceProvider.php(49): Illuminate\Auth\AuthManager-&gt;__call('user', Array)
#5 [internal function]: App\Providers\AuthServiceProvider-&gt;App\Providers\{closure}(NULL)
#6 /var/www/rms_api/vendor/illuminate/http/Request.php(513): call_user_func(Object(Closure), NULL)
#7 /var/www/rms_api/app/Components/RequestLogger/RequestLogger.php(133): Illuminate\Http\Request-&gt;user()
#8 /var/www/rms_api/app/Exceptions/H in <b>/var/www/rms_api/app/Http/ApiGuard.php</b> on line <b>204</b><br />
<br />

<b>Fatal error</b>:  Uncaught ErrorException: Undefined property: stdClass::$exp in /var/www/rms_api/app/Http/ApiGuard.php:204

Stack trace:
#0 /var/www/rms_api/app/Http/ApiGuard.php(204): Laravel\Lumen\Application-&gt;Laravel\Lumen\Concerns\{closure}(8, 'Undefined prope...', '/var/www/rms_ap...', 204, Array)
#1 /var/www/rms_api/app/Http/ApiGuard.php(182): App\Http\ApiGuard-&gt;mutateUserInformation(Object(stdClass))
#2 /var/www/rms_api/app/Http/ApiGuard.php(111): App\Http\ApiGuard-&gt;resolveUser(Object(stdClass))
#3 /var/www/rms_api/vendor/illuminate/auth/AuthManager.php(294): App\Http\ApiGuard-&gt;user()
#4 /var/www/rms_api/app/Providers/AuthServiceProvider.php(49): Illuminate\Auth\AuthManager-&gt;__call('user', Array)
#5 [internal function]: App\Providers\AuthServiceProvider-&gt;App\Providers\{closure}(NULL)
#6 /var/www/rms_api/vendor/illuminate/http/Request.php(513): call_user_func(Object(Closure), NULL)
#7 /var/www/rms_api/app/Components/RequestLogger/RequestLogger.php(133): Illuminate\Http\Request-&gt;user()
#8 /var/www/rms_api/app/Exceptions/H in <b>/var/www/rms_api/app/Http/ApiGuard.php</b> on line <b>204</b><br />

1 Answer

0 votes
by

Hello,

There was a temporary issue with the RMS API, which has now been fixed.

Please let me know if you encounter any more issues with the RMS API.

Best answer
by
Acknowledged, it's working for me now. Thanks!