8395 questions

9876 answers

15663 comments

14147 members

0 votes
47 views 6 comments
by

Hi

After installing FW 7.0 we can't connect to the device with tcp on the mobil interface

With FW 6.07.5 the mobile interface was configured on wwan0 with mtu 1360

root@Teltonika-RUT955:~# ip a

11: wwan0: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1360 qdisc fq_codel state UNKNOWN group default qlen 1000

    link/ether aa:a6:7f:55:9b:56 brd ff:ff:ff:ff:ff:ff

    inet 100.67.147.166/30 brd 100.67.147.166 scope global wwan0

But with FW 7.0 it seems to have moved to qmimux0 and a mtu of 1500

root@Teltonika-RUT955:~# ip adr 

16: qmimux0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000

    link/none

    inet 100.67.178.134/32 brd 255.255.255.255 scope global qmimux0

Do I need to configure FW 7.0 to have MTU on the mobile interface to be 1360 to get the same behaviour as FW 6.0 or is there another workaround or fix in newer FW? 

Kindly

Magnus Bergroth

1 Answer

0 votes
by

Hello,

Please try to navigate Network > Interfaces > Edit (mobile interface) > Advanced settings and try to save 1360 MTU value in a field called Override MTU.

Regards.

by

Hi

I change the mtu to 1360 in the GUI

But it still 1500 on the interface:

16: qmimux0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/none
    inet 100.67.178.134/32 brd 255.255.255.255 scope global qmimux0
       valid_lft forever preferred_lft forever

Kindly

Magnus

by

Then you could try to change it via CLI by using command:

ifconfig qmimux0 mtu 1360

by
That solved the problem

Should it be possible to set the MTU via the GUI? As I guess the ifconfig setting is not permanent?

<<Magnus
by
You can insert this line in System > Custom Scripts. This way this command will be executed every time your router comes online.
by
Thanks, will add it to the startup script that will solve our problem.

Is the GUI broken as it doesn't work to set the MTU?
by
I will investigate this further, theoretically, it should set your interface to a specified MTU value. I will report that to the RnD department.