11324 questions

13494 answers

21161 comments

31592 members

+1 vote
1,522 views 13 comments
by

Hello, i have connected my rut240 with spusu sim card to my helium miner.

Because i saw relayed status on miner i have added a port fowarded rule in my router, adding also a static ip address to my miner.

I have also put the nat of the miner on 'passthrough' and i have opened the 44158 port on the router but the relaying issus is not resolved.

When i check if the port 44158 is open it said 'closed'.

Someone can help me?

Thank you

Andrea

by

@Tomas, the first thing you do is call the ISP to remove CGNAT for that.

by
Any one get there 44158 open on a rut240?

1 Answer

0 votes
by
Hello,

Could you elaborate on how do you connect your miner to RUT240? IS it WAN to LAN or LAN to LAN? Also, how do you check port status?

Could you add full configuration screenshots right there so we could understand your use case better.

Regards.
by

Hi,

thak you cfor your fast reply. i have connected miner by LAN and check port status by this site 

https://www.yougetsignal.com/tools/open-ports/

Here my router configuration:

if you required i can generate some export from router.

Best regards

Andrea

by
Hello everyone,

any idea?

During these day i have made some tests.

I tried to use ipstatico.org to make a vpn connection but port 44158 still close.

I tried to use DMZ but still not improvment

On my miner in diagnostics i can see port 44158 open but nat symmetric: what it means? How can i fix it)

THank you

Andrea
by
Hi Andrea... any chance you found a solution for this? Struggling also... Mario
by
Hello,

Could you draw a full topology scheme?To better understand how RUT should work together with Helium miners.
by

It’s REALLY IMPORTANT that the Bobcat device communicates with the Helium network through port 44158 so it should always remain open and (if there is no option from the Internet Service Provider to get a static IP) one needs to create a static ip lease for the Bobcat device. Those 2 things are really important. In Bobcat device diagnostics (which one accesses by entering the IP of the device), as on the previously attached image it has to say: port 44158 open, connected: yes, dialable: yes, NAT: NONE (important!, in Croatia-EU we get that by calling the ISP and asking to remove CGNAT) AND the listen_addrs MUST NOT BE p2p/... but must start with ip4/(IP address)/tcp/44158. 

For me, this used the work, until it didn’t (for example if someone unplugged the whole setup from the wall-electricity). And sometimes it did work, sometimes it didn't... So Passthrough + static ip lease + port forward 44158 for that static ip lease. 

GristleKing is well respected in the helium community, he wrote an article on setting up RUT240 for off-grid-mining here: https://gristleking.com/step-by-step-rut-240-for-helium/ but unfortunately, not all of the steps are said… 

by

Furthermore, a guy name Oliver wrote an article on Medium about helium mining over a cellular connection here https://medium.com/@oliverswitzer_91379/an-in-depth-guide-how-to-setup-your-helium-hotspot-over-a-cellular-network-39763d443c99 There is also a topology scheme but I can't vouch if it is a correct one: 

There is also heliumstatus.io that lets you ping the hotspot or see if the connection is open if you know the miners name (on RUT240s for example: Round Vanilla Dragonfly, Slow Hotpink Camel, Sweet Jade Seahorse... 

Hope this helps. I've been told I need to stop after doing the Passthrough by (for now) this doesn't seem to work OR don't touch the Passthrough but just do a STATIC IP LEASE + PORT FORWARD 44158 for that IP LEASE. 

Anyway, hope this gives you help us so we can all go buy some more RUT240s and spread the word that they are the easiest-best option for helium mining. :) 

Sincerely, Mario

by
Thank you for the information. I will look into it as soon as possible.
by

@VykintasKuzma, here is also the importance of being non-relayed directly from helium network: https://docs.helium.com/troubleshooting/understanding-witnesses/

by
@VykintasKuzma, any chance you had time to look into this?
by

Hello,

In order to make the port forward work it's necessary to make sure that the router has a public external (WAN) IP address. Please double check if router WAN IP address falls in the range within any of the following addresses: 

10.0.0.1 - 10.255.255.254

100.64.0.1 - 100.127.255.254

172.16.0.1 - 172.31.255.254

192.168.0.1 - 192.168.255.254

If this is indeed the case, then this means that the WAN IP is a private IP address. In this case, it is a must to get an external public IP address from ISP or, if there is no way to obtain an external public IP address, please refer to this guide for private WAN IP solution using VPS.

Best regards,

Tomas.

by

@Tomas, the first thing you do is call the ISP to remove CGNAT for that.