8400 questions

9885 answers

15678 comments

14155 members

0 votes
37 views 2 comments
by

After installing ntpd on RUT240, it is unable to run due to a wrong version of libcrytpo

root@Teltonika-RUT240:/# opkg install ntpd
Installing ntpd (4.2.8p6-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/ntpd_4.2.8p6-1_ar71xx.ipk.
Installing libcap (2.24-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/libcap_2.24-1_ar71xx.ipk.
Configuring libcap.
Configuring ntpd.
root@Teltonika-RUT240:/# /sbin/ntpd -g -u ntp:ntp -p /var/run/ntpd.pid -n
/sbin/ntpd: can't load library 'libcrypto.so.1.0.0'

It would be great to have a solution for this, other than diving in and trying to build the package myself?

It seems that the ntpd package is built against an older version of libcrytpo. This error also present with openssn-client, and there's a ticket for this here: https://community.teltonika-networks.com/37593/ssh-is-unable-to-load-libcrypto-so-1-0-0

1 Answer

+1 vote
by
Hello, joernsn,

Thank you for contacting us.
I was able to replicate this issue and consulted with our RnD department about this issue.
I would like to inform, that this issue is known and planning to be solved with future firmware version.

Best regards,

Sigitas K.
by
Thanks. Will this ticket be updated?
by
Hello,

If everything goes according to the plan, new firmware release is planned at the end on this moth.
It should solve this issue.

Best regards,

Sigitas