8752 questions

10397 answers

16334 comments

15445 members

+1 vote
202 views 2 comments
by
On my RUTX12 I have to use firmware V5 (last version of it), because V6 was buggy and V7 is even more. Both have this problem that after a few hours, my modem disapears. In V6 the icon is gone and I can not go to modem settings and restart it, but it works. In V7 the modem says there is no SIM card in it, so I can not see anything. Traffic logs freeze the whole router etc. V5 is usable, does not have this serious problems with modem, but it has it's own quirks like 20 entries limit to WIFI MAC list etc., that were added later.

I tried SIM cards from 2 providers. Same problems. Using 2 SIM in V7 has so much freezes and is so bad, I had to revert back.

Is there ever going to be another good and stable firmware?
by 1 flag
Jerry, thank you for posting this!  I spent a good 15 hours trying to get my RUTX11 working on v6 (what it came with) and then v7... they are 100% Garbage!  They NEVER saw any 4G signals and only one 3G.... even though the AT&T/T-Mobile tower is only 1/2 mile from my house.

I just installed v5 and its working!  Sees many 4G signals (3G also). They show very strong -59 dBm where v6 & v7 shows -95 dBm on the RARE instance it saw any signal at all.

I have worked for several hardware and software companies and bought/installed a thousand computer devices in my 49 years... this is literally the worst experience with any device, ever. I had the RUT950 and it always worked fine.

I hope all the other RUTX users see this thread!
by
Unfortunately, I can only agree that Teltonika seems to have totally lost control of its RUTX FW quality, and I am really worried with this and consequently at this point I cannot recommend anyone to purchase a Teltonika router because of this FW degradation.
Teltonika HW is nice for the price. FW features on the paper are also nice with even quite clever ones, but so few of them work actually smoothly, e.g. how to use data limit without a working automatic data counter reset...
Last FW7.0 makes just things worse than ever, with terrible freeze in WEBUI, in addition to break some big feature like profiling... Just a nightmare. From my side I didn't experience some specific modem behavior degradation regarding previous FW version on the top of a the general painful WEBUI lagging issue. However I wonder how such kind of huge regression can occur and how does Teltonika test its FW to make such disaster possible.
To Teltonika R&D, please stop to develop any new feature and just try to focus on making work existing ones smoothly and regain FW quality under your control. But as an optimistic person, I am convinced this is likely what is on going regarding the delay to get a new FW version :-) (nevertheless and carefully I also noted that we had to wait for a long time to get this terrible release 7.0...)
From my side I have also downgraded to FW2.5.2, as to be honest, I am a bit tired to take time to report and explain issues I observed since release 6, with up to this point no visible improvement at the end. Really disappointing.

1 Answer

0 votes
by

Hello,

First of all, thank you for the feedback - the more of it the merrier. We're always looking to pin down all and any sort of issues and patch them up, so if there are some quirks with certain functionalities of the router, please make sure to let us know, it's tremendously helpful!

That being said, I'd like to ask you to try and upgrade your routers to the most recent firmware version 7.1. It's been improved quite a lot since the older firmware version(s) with a ton of updates to existing features and bug fixes. You can find newest firmware versions for your router in our wiki on this page: https://wiki.teltonika-networks.com/view/FW_%26_SDK_Downloads

Best regards,

Tomas.