10924 questions

13027 answers

20297 comments

27234 members

0 votes
324 views 7 comments
by

I'm having irregular issues with the RUT240 gateway, I am trying to use the WAN port for network with mobile and wifi as fallback but frequently the gateway does not obtain an IP address from DHCP at boot and will remain in that state until it is powered off and on.

Here are the logs dmesg output (github.com)

1 Answer

0 votes
by
Hello,

Which firmware version your RUT240 is currently at? Could you set a static IP on wired WAN configuration for tests instead of DHCP? How much time you have waited for a router to obtain IP?

Regards.
by

Have waited several hours when it's in this state and it remains in the same state (have tried replugging the WAN ethernet whilst in this state and nothing happens, not even any log messages). Have also tried  setting a static IP and it still doesn't provide an internet connection. 

I left the router powered on overnight and I came back to it this morning and it has an IP, but also have this error in the logs.

logread.log (github.com)

by

At this moment I would suggest re-flash your firmware to RUT2XX_R_00.01.14.4 via the bootloader menu: https://wiki.teltonika-networks.com/view/RUT2xx_Firmware_via_The_Bootloader_Menu 

Please inform me if the unwanted behavior continues.

Best regards.

by
Sorry forgot to include what version of FW I was on, I'm using RUT2XX_R_00.01.14.3 but I will try the latest firmware
by
It is important that you could try to install via the bootloader.
by
Okay, I've updated it through the bootloader and I'm sill having the same issue.
by
By any chance do you have any other device that could act as DHCP client to your wired connection source? There could be an issue with DHCP server side.
by
Same issue here. Out of 6 new RUT240's I've received in the past month, only one has working DHCP on the WAN port. 3 came with firmware that isn't even listed on the website as being a real version, but I was able to update them to the latest firmware. Still nothing. Wiped config, factory reset, nadda. There doesn't seem to be a dhcp client installed on the device as far as I can tell.
Static IP configuration works fine, so there's nothing wrong with the port. Just never even attempts a DHCP request.
I've also watched the LAN for a DHCP broadcast, but none is ever sent out. It's like they just forgot the DHCP client in most versions of the firmware for this unit.

I'm a little miffed as I just switched over to Teltonika from Cradlepoint, but now I've got a ton of dead devices and nothing I can deploy to clients.