8413 questions

9899 answers

15703 comments

14199 members

0 votes
44 views 1 comments
by
I have been trying to setup a RUT950 to L2TP traffic between 2 sites, L2TP because the protocol needs to forward on the same subnet and doesn't route.

We can use anything as a server and currently using a Fortigate appliance.

IPSEC comes up, L2TP comes up, I can ping the ips on either end of the tunnel from the server end and on the RUT, however trying to reach any of the L2TP subnets fails.

It appears like there is no bridging between lan and l2tp and no options to do so via the gui, so packets are not even getting to the L2TP tunnel.

Tried adding bridge to l2tp network config via CLI that didn't help either.  There are so many mixed up configs and even the wiki has config templates about getting L2TP between the RUT but not getting it down to the LAN.

1 Answer

0 votes
by

Hi, 
Without your network topology is a bit hard to understand what you want to reach, but perhaps this example could help to you: https://wiki.teltonika-networks.com/view/L2TP_over_IPsec

by
Honestly the topology is kinda simple.

Client Device 10.10.0.1/15  - RUT950 - L2TP server(trying to use openwrt x86) but that can change. - remote lan server 10.10.0.7/15

The client device is a control system we are trying to manage remotely and only works on the same l2 domain so doesn't route. If it did it would be easy, need multicast support as well.

Easy enough to do on a beefy router with cisco or co with xconnect/mpls etc but want to do on smaller device.

The use of L2TP is not the requirement, its the layer 2. End-to-end.

I worked out the bridging eventually but still struggling to get end-to-end connectivity. It might not work.