10464 questions

12475 answers

19401 comments

21925 members

0 votes
292 views 1 comments
by

Hi,

I recently started to update our Routers from RUT9XX_R_00.06.08.5 to RUT9_R_00.07.00 and subsequently to RUT9_R_00.07.00.02. However since we configure all our routers via the uci I noticed that uci-reload results in an error saying that uci-reload was not found. The command usage page however still prescribes the final steps as 

# uci commit dhcp
# luci-reload

I havent'n seen anything in the changelog affecting the uci neither. Is luci-reload debricated or is this a bug?

Regards 

Ian

1 Answer

0 votes
by
Hello,

I apologize that the guide is not updated properly. With the 7.0 firmware release, we have moved our WebUI from Luci to vuci and luci-reload is not required anymore as it was used just to refresh WebUI.

Regards.
by

thanks for your comment. However when I change the LAN IP address, I remeber with the old firmware after a 'uci commit' and 'luci-reload' the the router was offline for a few seonds and the new LAN configuration was active (ping to new address worked). Now I have to reboot in order for the new network configuration to be active.

Another thing I noticed while configuring a RUT240 with the new firmware was, everytime I change the APN via uci command 

uci set network.mob1s1a1=interface
uci set network.mob1s1a1.proto='wwan'
uci set network.mob1s1a1.modem='1-1'
uci set network.mob1s1a1.sim='1'
uci set network.mob1s1a1.pdp='1'
uci set network.mob1s1a1.method='nat'
uci set network.mob1s1a1.pdptype='ip'
uci set network.mob1s1a1.delegate='0'
uci set network.mob1s1a1.metric='2'
uci set network.mob1s1a1.auth='none'
uci set network.mob1s1a1.force_apn='-1'
uci set network.mob1s1a1.apn='new.apn.com'

after the reboot the config shows

network.mob1s1a1=interface
network.mob1s1a1.proto='wwan'
network.mob1s1a1.modem='1-1'
network.mob1s1a1.metric='2'
network.mob1s1a1.sim='1'
network.mob1s1a1.pdp='1'
network.mob1s1a1.username='apn'
network.mob1s1a1.password='apn'

network.mob1s1a1.method='nat'
network.mob1s1a1.pdptype='ip'
network.mob1s1a1.delegate='0'
network.mob1s1a1.force_apn='-1'
network.mob1s1a1.auth='pap'
network.mob1s1a1.apn='apn.es'

wwan0 interface also is DOWN.

I have to turn on auto APN, save the configuration, and then change back to custom APN in order to make it work. After that wwan0 is UP again and mobile traffic establishes a connection.

You got any ideas?

Ian