FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12011 questions

14288 answers

22528 comments

35931 members

0 votes
274 views 0 comments
by

Hello everyone,

I have several RUTX14 (and RUTX12) routers.

These routers are interconnected by an openvpn TUN (layer 3) network.

On the LAN side of each router, one device joins a multicast group. This group must be common to all local networks. So it has to be forwarded in both directions over the VPN network (2 hops).

Unfortunately, unless I missed something, there doesn't seem to be a menu to configure PIM, igmpproxy... or smcroute via the web interface.

So I tried installing pimbd via the CLI using opkg install pimbd.
When I run pimdb, I get the following errors:


root@Teltonika-RUTX14:~# pimbd
 pimbd: Unexpected sysctl value: /proc/sys/net/ipv6/conf/all/mc_forwarding = 0
 pimbd: Unexpected sysctl value: /proc/sys/net/ipv4/conf/all/mc_forwarding = 0
 pimbd: Unexpected sysctl value: /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts = 1


While I manage to set icmp_echo_ignore_broadcasts to 0,
I cannot set mc_forwarding to 1 for either ipv4 or ipv6.

The following commands are ignored:

root@Teltonika-RUTX14:~# sysctl -w net.ipv4.conf.all.mc_forwarding=1
root@Teltonika-RUTX14:~# sysctl -w net.ipv6.conf.all.mc_forwarding=1
root@Teltonika-RUTX14:~# cat /proc/sys/net/ipv4/conf/all/mc_forwarding 0
root@Teltonika-RUTX14:~# cat /proc/sys/net/ipv6/conf/all/mc_forwarding 0


I have also tried setting these variables in /etc/sysctl.conf, but the values remain unchanged even after a reboot.

Please, could you help me to make a bidirectional multicast forwarding ?

1 Answer

0 votes
by

Hi,
Unfortunately we do not have instructions for this, but maybe this article could help to you: https://openwrt.org/docs/guide-user/network/wan/udp_multicast