8333 questions

9805 answers

15587 comments

13966 members

0 votes
18 views 0 comments
by

I can't install/upgrade mqtt_pub.

root@Teltonika-RUT950:~# opkg install mqtt_pub
Upgrading mqtt_pub on root from 2021-06-22-1 to 2021-11-12-1...
Downloading http://opkg.teltonika-networks.com/29a77a45385fb7747f4c8eb7cbf35f0171fb451979a1d7fa6a95c5d79851202e/mqtt_pub_2021-11-12-1_mips_24kc.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for mqtt_pub:
 *     libubus20210630
 *     libubox20210516
 *     libblobmsg-json20210516
 * opkg_install_cmd: Cannot install package mqtt_pub.

The device is an ordinary RUT950 with firmware 00.07.00.2.

The above example is from a RUT950, when I first experienced it, it was on a fresh (no previous version of mqtt_pub) RUT955 earlier today.

1 Answer

0 votes
by

Hello,

On the RutOS 7.0 a MQTT service is removed to the package manager. You can download and install on the Web Ui Services -> Package Manager page. Or download all package zip file here:

https://wiki.teltonika-networks.com/view/RUT950_Package_Downloads#Latest_Packages_.28from_07.00.29

Regards.