8331 questions

9798 answers

15585 comments

13962 members

0 votes
38 views 1 comments
by

Hello,

I have been unable to enable ipv6 on my RUT240's Mobile WAN. I have enabled the settings mentioned in the thread: https://community.teltonika-networks.com/26900/rut240-ipv6-support-mobile-network but still can't get an ipv6 address. My device is using firmware RUT2XX_R_00.01.14.4. I have done the folowing:

  1.  enabled ipv6 in System > Administration
  2. Set DHCPv6 client in WAN

Am I missing anything, or is ipv6 support missing/incomplete?

1 Answer

0 votes
by

Hello,

A new firmware version RUT2_R_00.07.01 has been released. If you have the opportunity, you can test IPv6 on it.

Note: FW version RUT2_R_00.07.01 contains many major updates, some of which made certain functionalities of RUT240 no longer available to utilize. To successfully upgrade RUT240 from Legacy firmware (RUT2XX_R_00.01.14.1 and below) to RUTOS (RUT2_R_00.07.01 and up), you must first upgrade to the latest Legacy firmware (RUT2XX_R_00.01.14.3 and up) and then upgrade to latest RUTOS firmware.

Best regards.

Best answer
by
Thank you,

I had an opportunity to test that new firmware. The following settings have gotten things working:

PDP Type = ipv4/ipv6 in Interfaces > MOBS1A1

Router Advertisement-service = server mode

DHCPv6-service = server mode

Appears to be working okay.