subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
5,499 views 4 comments

I'd like to build up a WAN failover via wired WAN. I'd like to use the internet Uplinks in the following order:

1. Wired WAN

2. Mobile WAN (SIM1/SIM2 Failover)

Unfortunately at one point the Wired WAN Connection disappears under "Network" --> "WAN" and I'm unable to set up this configuration. Is there a way to configure this?

Best regards


1 Answer

0 votes
by anonymous


This is strange indeed. Could you provide us with the router's Troubleshoot file? You can download it from the System → Administration → Troubleshoot page. This might help me identify the problem.

However, I suggest you delete any confidential information from the the router's configuration before you upload it (like phone numbers, passwords, etc.)

Best answer
by anonymous

thanks for your help. You can download the file here:

Password for the config is 0000. I had to change several confidential things, but the problem persists. I hope you're able to find the reason. My assumption is, that wired wan failover disappears as soon as I add the second lte card.

Best regards

by anonymous
Ok, I can definitely see why wired WAN is missing - there's a mismatch of network interface names in the config. I can't find out why though.

You can fix this by logging in to the router via CLI (Services → CLI; login: root; password: router's password) and executing the following commands:

uci set network.wan2.ifname='eth1'
uci commit
/etc/init.d/network restart

This should fix the WAN issue. However, the issue appeared after multiple configuration changes (as I said, I can't really see where exactly). So I would recommend upgrading to a new firmware (without settings) and configuring it over again in case something else that I can't see isn't right.
by anonymous
Thanks, I'll try.

I checked for updates, but didn't expect to upgrade in many steps to a newer firmware.

I'll let you know about the results. Maybe I'm able to reproduce how I got rid of the wired interface.


I have the same issues. I have a setup, where my wired WAN is the primary, fallback to Wifi (client) WAN, and thirdly to mobile SIM WAN.

This setup worked fine for about 3 months or more ... and then suddenly, without any config change or so, the Wired WAN disappears from the list... It cannot be selected, and even, as there is a physical and working network cable in the WAN port, the image displays it as not connected - though the traffic light of the WAN port flickers...

I had the same problems in the beginning when i started using the modem. Then I had to factory reset it, and do the whole configuration again !
Now again out of the blue, the problem is back....

It is very annoying because I haven't touched the config in months !!!


1 - I tried the command suggested earlier in this thread, then the wired interface appears again, but one of the SIM mobile WAN's has disappeared. And also, the WAN does not come up (no dhcp address).  -> i had to switch between static and dhcp config to actually "kick it back to life..."

2 - now all of a sudden my SIM WAN mobile connection is having problems... I had to restart the modem a couple of times...

3 - it keeps telling me there is a firmware upgrade, but I already installed it twice (it has the same version !!!) and still keeps alerting me it has an update....