subscribe to our Youtube


14193 questions

16848 answers


54244 members

0 votes
225 views 4 comments
I'm experiencing some connection problem wanting to use relay function of a TRB (142).

What we are doing:

A TRB142 is powered in 12V with solar panel/battery. + is directely connected and also another device with RS232 connection.
The device "-" is connected to the I/O out, I/O in connected  to bettery -
Everything is ok so and the relay function of the TRB works perfectly.

The problem comes when I connect RS232: if no ground, the relay works but communication does not worl properly.
When i connect the GND, it "bridges" both devices and the relay off has no effect.

I tried to use the relay with [­ + ] because my devices uses 5-16V, but it does not work.

Any idea ? Problem with the Teltonika device/relay or bad wiring?

Best regards.


Could you please confirm that you're using the latest available firmware on your TRB142 gateway? The current firmware version should be TRB1_R_00.07.01. Please note that if you are using FW version TRB142X_R_00.01.06.1 or older on your TRB142 gateway, you will need to follow these instructions in order to successfully upgrade your device's FW to a later version.

Additionally, you can find the latest firmware with here.

Also, please provide a scheme to confirm how every device is connected.

Best regards,


1 Answer

0 votes


Yes, I'm using TRB1_R_00.07.01.
Previously it worked with an older Firmware, but I tried to downgrade and it doesn't seem to be better.

Here is a basic scheme:

If I connect the 5 pins the relay does not work becase I "bridge" the -/GND.

If I don't put this wire and only the dotted gray one, it doesn't work.

But I tried this morning with a TRB145 I own and it seems to work, so I would think that there is a power problem with the I/O on the 142.
Or is there a mistake somewhere?
Best regards and thanks for any help/advice




Thank you for the scheme. From your description I understand that you tried this with both RS485 (TRB145) and RS232 (TRB142) and everything was working using the RS485 (TRB145). Could you please confirm that the correct RS232 wiring is being used for this connection? Perhaps the RX/TX pins are the opposite of what they should be right now? You can read more about RS232 pinout and connectors here.

Also, could you please confirm that this is an external relay and what exactly should be controlling it?

Best regards,


Hello. Thanks for the reply.
Yes. I'm using a RS232 consumer device, so I initially tried with a TRB142.
Because I hat another project with a RS485 device, I also tried it... and it worked.

I assume that the wiring is correct: "straight crossed cable pinout" on the page you linked.
I did so on the 2 systems that are running now.
But impossible to make it work with the new TRB142. I initially thought that the TRB142 has a problem, but I hat the same problem with another TRB142.
The only difference ist that serial number starts with 111xxx. On old devices (where it works) are 110xxx.
Did something change at Teltonika's side?

About the relay: no, at this time it is not an external one, but I perhaps what I'll have to do.
I wanted to use the I/O functions and scheduler of Teltonika and use the pins 3 and 4 for that

From all the information the most likely scenario is RS232 cabling/communication being an issue. The primary reason why that could be an issue is because you've mentioned the entire scheme working with your TRB145 as well as RS485 cabling. Could you please let me know which pins are used when connecting devices with RS485?

Also, just to be absolutely sure - do both the TRB142 and the consumer device have female RS232 connectors?

Additionally, I would like to ask you a question regarding the relay - I believe you've mentioned it's not an external one, so if I understand correctly, you want to use the TRB142 as a digital relay?

Best regards,