10914 questions

13004 answers

20271 comments

26938 members

0 votes
175 views 1 comments
by
We have a ISP that provides access using DHCP, so we have to set up WAN DHCP client.

Unfortunately the Teltonika routers are not able to resolve an adress. Testing with other routers or even only with a PC we get an IP and connection without problems.

I tried a RUTX08 and a RUTX10. Even with different firmware versions (newest and also older one). Of course we tried the factory reset but everything without success.

It brings up the link on the WAN, but then we get udhcpc: sending discover and then ubi0 error: ubi_open_volume.part.0: cannot open device 0, volume 2, error -16

Attached the troubleshoot from the RUTX08 and RUTX10 and a picture of the system log.

1 Answer

0 votes
by

Hello,

Please make sure that the firewall on RUTX08 and RUTX10 isn't blocking DHCP address renew from WAN. Double check if the necessary traffic rule is enabled by navigating to "Network>Firewall>Traffic rules" and please make sure that the "Allow-DHCP-Renew" is turned on.

Additionally, if the traffic rule is enabled and your devices still cannot obtain lease, please proceed to reinstall firmware by using the Bootloader method as described here: https://wiki.teltonika-networks.com/view/RUTXxx_Firmware_via_The_Bootloader_Menu

If the issue isn't solved after these steps, please send me a private message with the troubleshoot file and include any related screenshots when trying to obtain the IP address via DHCP (give router some time to send a few requests).

Best regards,

Tomas.

by
Dear Tomas,

I did try to do as you suggest, Allow-DHCP-Renew is turned on.

In fact I get DHCP Adress from lot of routers but in particular not from the ISP that we use. I did also try to use another RUTX08 but with no success. There is something on the DHCP snooping process that does not behave correctly.

As told before, If I test the ISP with a common PC (Windows 10) or with a Frixbox asking for DHCP IP assignment I get the IP without problems.

I did not try the same with a RUT240, but same issue.