FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12012 questions

14293 answers

22535 comments

35936 members

0 votes
401 views 3 comments
by

We were unable to push routes from OpenVPN Server to OpenVPN Client on a RUT950 with Firmware Version RUT9XX_R_00.06.08.3 .

The "logread" command showed us the following problem after enabling VPN Client on RUT950:

Fri Dec  3 15:06:44 2021 daemon.notice openvpn(636C69656E745F42494D56504E)[3548]: PUSH: Received control message: 'PUSH_REPLY,route 192.250.xxx.0 255.255.255.0,route 192.250.yyy.0 255.255.255.0,route-gateway 192.168.zzz.1,topology subnet,ping 10,ping-restart 120,ifconfig 192.168.xxx.yyy 255.255.255.0'

Fri Dec  3 15:06:44 2021 daemon.notice openvpn(636C69656E745F42494D56504E)[3548]: net_route_v4_add: 192.168.xxx.0/24 via 192.168.xxx.1 dev [NULL] table 0 metric -1
Fri Dec  3 15:06:44 2021 daemon.notice openvpn(636C69656E745F42494D56504E)[3548]: net_route_v4_add: 192.250.yyy.0/24 via 192.168.yyy.1 dev [NULL] table 0 metric -1
Fri Dec  3 15:06:44 2021 daemon.warn openvpn(636C69656E745F42494D56504E)[3548]: sitnl_send: rtnl: generic error (-128): Network is unreachable
Fri Dec  3 15:06:44 2021 daemon.warn openvpn(636C69656E745F42494D56504E)[3548]: ERROR: Linux route add command failed
 

I highlighted the problem! The command "route add -net 192.yyy.xxx.0/24 dev [tun_name] couldn´t be sucessfully executed due to a missing dev name. This looks like a firmware bug to me.

After downgrading to Firmware Version RUT9xx R 6.07.05 everything was working as expected. For some reason it was doing a factory reset while the downgrade, although I checked the checkbox "keep settings". If you ask me, this is an absolutely NO GO. Our RUT router are very very far away from our office.

Was somebody else experiencing those problem?
Has anybody has a contact to the RUT950 firmware dev team?

2 Answers

0 votes
by
Hi,

Use the latest firmware version. Why do you need communication with developers? You can download outdated firmware https://wiki.teltonika-networks.com/view/Software_Development_Kit and fix everything that you want.

p.s. do not save the settings when updating the firmware. when switching from 6 to 7 exactly.

Best regards.
by
I didn´t see a fix of this problem in the changelog of latest firmware release xxx.08.4 or xxx.08.5, so I decided to downgrade. I don´t wanna fix it by myself, that is why I wanted to tell it to firmware devs.

If you can confirm a stable firmware what I shall use, I will do it in the future. This router is already 3000km far away from me.

thanks for the info regarding 6 to 7 upgrade.

Kind regards
by
Hi. At least the latest firmware version uses the latest versions of OpenWRT and OpenVPN, which could also have errors.

Best regards.
0 votes
by
Hello, I've got the same problem with rut955. I've been using 6.07.05 till new version came and didn't support downgrade. I did manage to workaround this problem by removing push from server (after upgrade to version higher than 6.07.05 device name of pushed route is set every time to wan not to vpn as have been before) and adding route in vpn client configuration in extra options (e.g. route 192.168.1.0 255.255.255.0). After reboot device updates it's routes from vpn server and uses locally configured path.
by

Thanks for the answer. I can´t change your settings on the openvpn server, coz it would effect to many clients.

We have experienced the same problem with the latest version "RUT9_R_00.07.01.4". The openvpn daemon on RUT955 still can´t receive push network from openvpn server.

Still the same log output of logread | grep vpn:

Tue Mar 15 14:21:06 2022 daemon.notice openvpn(VPNVSR)[4839]: net_route_v4_add: 192.168.xxx.0/24 via 192.168.xxx.1 dev [NULL] table 0 metric -1
Tue Mar 15 14:21:06 2022 daemon.notice openvpn(VPNVSR)[4839]: net_route_v4_add: 192.250.yyy.0/24 via 192.168.xxx.1 dev [NULL] table 0 metric -1
Tue Mar 15 14:21:06 2022 daemon.warn openvpn(VPNVSR)[4839]: sitnl_send: rtnl: generic error (-128): Network unreachable
Tue Mar 15 14:21:06 2022 daemon.warn openvpn(VPNVSR)[4839]: ERROR: Linux route add command failed

But this time I could execute the following command manually:
route add -net 192.yyy.xxx.0/24 dev [tun_name]
I added them in /etc/rc.local with a sleep 10 before, so after a reboot all routes are set. This works for me!
I hope telematika is fixing this bug soon though!