10512 questions

12517 answers

19444 comments

22040 members

0 votes
163 views 12 comments
by

Hello,

I want TRB142 to use as modem to send SMS from specific program as notification. After enabling services-> RS232-> and changing serial type to Modem and Mode to Full control, then connect via PuTTy and sending SMS via AT commands works fine, even physical device (LEDs) seems OK, device is connected to 4G, signal strength all 5 LEDs are on. BUT when I reboot the device then all 5 signal strength LEDs are flashing constantly every 1 sec. I tried to look on the internet for information but there is no info on the teltonika wiki what actually blinking LEDs means for this particular model. Also, connecting via PuTTy does absolutely nothing. I can't enter any commands. It seems that this particular configuration somehow corrupts the device. After disabling the RS232 service, router seems to be working fine again. Repeating the same procedure eventually comes back to the identical issue. Tried this with two different TRB142 routers with the latest FW (TRB1_R_00.07.00.1). Is this a firmware issue?

1 Answer

0 votes
by

Hello,

When you enable "Modem mode: Full control" option in "Services -> RS232" menu, you transfer all LTE modules control to connected RS232 device. From that point in time, RS232 takes full control over TRB1's LTE module. This is the reason why mobile LEDs stop working and why you can no longer interact with device through SSH using "gsmctl" function.

 - If you are indeed planning to control TRB1 from RS232 device (i.e. so that it could send SMS messages using AT commands), then do not focus on device's mobile LEDs and stop tests through SSH. Instead, connect live RS232 equipment, which can send AT commands over RS232.

 - Meanwhile, if you actually want to keep controlling device via SSH (Putty), then you can do so with default device's configuration. I.e. you do not need to enable "Modem mode" in order to interact with device through SSH.

by
Entering SIM PIN through WebUI only works, when router has control over its LTE module. Since you are in "RS232 modem mode", as mentioned in previous messages, router's mobile services are disabled and cannot send PIN code to the SIM card.

AT+CPIN command should work, since this is exact same command, which router's internal services are using when device is not in "RS232 modem mode". I assume you have entered 4 digit PIN code after "AT+CPIN=" message, just removed it in the picture, correct?

If you are indeed unable to enter SIM PIN, another option is to disable SIM PIN on this SIM card. That should solve your issue.
by

Correct.

Regarding SIM PIN - I am using AT+CLCK="SC",0,"<PIN>" (where <PIN> I enter SIM actual PIN) command to disable SIM PIN but again getting ERROR. How can I disable SIM PIN then?

by

Please try to disable RS232 modem mode. Then connect to device via SSH (Putty application):
 - SSH login: root

 - SSH password: <your device's password>

and use the following command:

gsmctl -A "AT+CLCK=\"SC\",1,\"1111\""

where 1111 would be replaced with actual SIM card's PIN.
by

OK, it helped but instead of this 

gsmctl -A "AT+CLCK=\"SC\",1,\"1111\"" 

I used this command and it worked.

gsmctl -A "AT+CLCK=\"SC\",0,\"1111\""  -> changed from 1 to 0

Seems working as expected right now. Thanks for your help. Anyway, for me this looks like an issue if I can't configure or disable SIM PIN after enabling RS232 with Modem mode: Full control is enabled.  Again is this somehow related to FW?

by

Hello,

I took TRB142 and installed same firmware into it as you mentioned in the beginning (TRB1_R_00.07.00.1). I put SIM card in device with disabled SIM PIN and enabled modem mode: full control.

I connected to TRB142's RS232 port via USB-to-RS232 adapter and was able to sent "AT+CLCK="SC",1,"<PIN>" " command. It enabled SIM PIN on the device.

After reboot device responded to "AT+CPIN?" with "+CPIN: SIM PIN". This is an indication that CLCK command worked.

I tried using "AT+CPIN=<PIN>". It worked as well and device responded with the following answer sequence:

  • OK
  • +CPIN: READY
  • +QUSIM: 1
  • +QIND: SMS DONE
  • +QIND: PB DONE

I was also able to send SMS message afterwards.

Finally I send "AT+CLCK="SC",0,"<PIN>" " command to disable SIM PIN and rebooted the device. After reboot device responded to "AT+CPIN?" with "+CPIN: READY". That means that SIM PIN was successfully disabled.

---------------------------------------------------------------------------

In conclusion: there is no issue with TRB142 device or its TRB1_R_00.07.00.1 firmware version. SIM PIN can be both entered and enabled/disabled through RS232 interface in Modem mode: full control.