10888 questions

12975 answers

20230 comments

26226 members

+1 vote
335 views 7 comments
by
Hi,

I have followed the instructions for the rut240 to run through a vps (wireguard). Everything appears to work fine including port 44158 being open on the vps ip address. The issue is it still appears to be relayed and the NAT type is Symmetric. Can you please help me work out what is wrong?

Thanks,

Brett

1 Answer

0 votes
by

Hello,

As far as I know the "relayed" status can remain for quite a while after configuring the port forward. If the port forward is working from the outside (WAN) and it shows as "Open" when checking with external tools, there is nothing that Teltonika or the end user of the Helium miner can do as it all depends on the Helium network reacting to changes in due time at that point.

Just in case, let me know if the port 44158 is being shown as "open" for you. To verify if specific port is open to the internet, we recommend using this website: https://www.yougetsignal.com/tools/open-ports/

Best regards,

Tomas.

by

Hi Tomas, 

I have configured my helium hotspot based on scenario # 3. Port 44158 is successfully open (website: https://www.yougetsignal.com/tools/open-ports/) but the miner is relayed.

In my case, I can see from the rut240 backend that:

  • the Linode virtual private server is sending data to the private IP address of rut240 through port 51820
  • the helium hotspot is sending data through port 44158 to some AWS IP addresses.
Do you have any idea how long it will take to update the miner relayed status? Alternatively, did I miss something to bring the hotspot how of relayed status?
Thanks for your help and support.
All the best
by

Hello,

From the looks of it, the port is open and listening. You can test it by temporarily disconnecting the miner and then re-checking whether the port is open or closed. If the miner is disconnected and the port is closed, then the configuration is correct. Once the miner connects back to the RUT240, the port should become open again. In that case the configuration is pretty much done. At this point unfortunately it is all up to the Helium network to confirm that your device is not being relayed. Also, just to be absolutely sure, could you double-check if the UPnP is disabled on your device? You can find this setting here: 

For firmware v7 and higher the setting can be found here: https://wiki.teltonika-networks.com/view/RUT240_UPNP

For legacy firmware (v6 and below) the setting can be found here: https://wiki.teltonika-networks.com/view/RUT240_UPNP_(legacy_WebUI)

Make sure the UPnP setting is disabled. Apart from that, as long as the port is displayed as open from the internet side, I'm afraid there is not much that we nor you can do. I've seen some people on the internet saying that they've rebooted both their miner and the router but the status remains as "Relayed" for at least a few weeks. If it is possible, please reach out to the Helium support team, perhaps they'll be able to provide you with some additional information regarding this case.

Best regards,

Tomas.

by
Hi Tomas,

I tested the port as you mentioned above. If the miner is not connected or turned off the port is closed. If the miner is connected and turned on the port is open.

I have upgraded the firmware of rut240 to v7. UPnp is a package that is available for download. As you mentioned that UPnp should be disabled so I haven't downloaded it.

It has been 3 weeks now that the miner is on relayed. Do you think it is just a matter of time for this to be fixed? Or do you to contact helium support team?

Thanks for your help and support.

All the best
by
Yes, in this case it seems like the port forward to the miner has been setup properly. Unfortunately, we cannot do much else other than to recommend contacting the Helium miner supplier and explaining them the situation.

Best regards,

Tomas.
by
Hi,

If anyone finds a solution to this i would be intrested to know. I to have port 44158 open and everything appears to be working correctly but after 4 weeks can not get the miner off relayed.

Thanks!
by
Did you ever find a solution to the relayed condition?  I have the same situation. I set everything up following Teltonika's wiki and it all went very well.  Port 44158 is open at my VPS and it also closes when the miner is disconnected and opens again when reconnected.  No UPNP never loaded onto the RUT.  Very frustrating.
by

Hi, 

The solution that worked for me was to configure the rut240 in full-proxy, as suggested by Tomas. You can find his comment here.

The solution is:

1/ Follow the instructions given in scenario 3 of the wiki

2/ When you reach the section "WireGuard peer Linode," the tutorial tells you to add <10.0.1.1/32> in the field of "Allowed IPs. Instead of doing so, you need to add in the field  "Allowed IPs  the IP address <0.0.0.0/1> and then click on the plus button and add the IP address <128.0.0.0/1> in the second "Allowed IPs" field.

It took several weeks for me to bring the miner of the relay status. So, be patient.

I hope this will work for you too

All the best