10490 questions

12505 answers

19431 comments

21988 members

0 votes
104 views 1 comments
by
Hi all,

I have just tested RS485 service on two TRB145 modems with firmware TRB1_R_00.07.01.

I use RS485 service On , Serial: Over IP, Mode: Server, and a specific port (e.g 1000) I need for my software to communicate with a device connected with RS485.

The port (e.g 1000) is not open by default (checked with nmap also) and therefore the device is unreachable.

The old firmware TRB1_R_00.02.06.1 had a setting in RS485 configuration where the port is open automatically, its not there in the latest firmware.

I reverted to firmware TRB1_R_00.02.06.1 with the setting "open port automatically" ON and it works fine (as the rest of the TRB145 I have set up and working with firmware TRB1_R_00.02.06.1).

Is there another way to open ports for Serial TCP over IP service in the new firmware?

I will be keeping firmware TRB1_R_00.02.06.1 for now.

Best regards,

Eleni

1 Answer

0 votes
by

Hello,

You can open ports via Web Ui Network > Firewall > Traffic rules > Open ports on router page. This provides a quick way to set simple rules that allow traffic on specified ports of the device. The article is an example of the Open ports on device section:

https://wiki.teltonika-networks.com/view/TRB145_Firewall#Open_Ports_on_Router

Please, review this and if you have any questions we will be happy to answer.

Regards.

Best answer
by
Hi,

thank you very much, it works with an open port rule in the firewall section. I'm sorry I didn't do my homework before posting.

Best regards,

Eleni