8899 questions

10555 answers

16568 comments

15924 members

0 votes
21 views 1 comments
by

Hello,

we operate several IOT connected machines that use a Teltonika RUT240 router with Olivia wireless simcards. With several machines now I have had issues with the mobile internet connection. We are running the routers with the 00.01.14.4 firmware.

Just this morning I was installing a machine with a sim card. Everything worked the way it was supposed to, the router provided internet via the sim card.

Half an hour later, the router was unable to connect to the internet. The router web interface showed that it was unable to receive any signal (0 dB). Between the mobile internet connection working and not receiving any signal, nothing was changed on the system. The location was still the same. I checked the antenna connection and router settings. All was in order. The apn is set according to the provider instructions. Rebooting the router did not fix the issue.

After running out of ideas, I replaced the sim card with another one by the same provider. Without changing anything else, the mobile connection worked, the router received a signal and I was able to connect to the machine via the sim card. This was today at 12:00.
I checked the machine again at 15:00, it was still online. One hour later at 16:00 it is offline again and has been so since.

What could be causing the router to not receive any signal? Our provider has suggested the router might be choosing the wrong operator, resulting in the 0 dB signal. Should the router not automatically select a different operator in this case?

Our provider also suggested to use the auto reboot function of the router to reboot the modem or restart the mobile connection. But if a reboot of the router does not fix the issue, the auto reboot function will not fix this either?

Updating the firmware at this point in time is not really an option, as our manufacturing is geared to work with the 00.01.14.4 firmware. So updating all our systems to a newer firmware involves quite a bit of work and change.

Any suggestions on fixes?

by
Just checked the site with the router to find out why it was offline again.

Logged in to the router web interface via Wifi connection and found following information: "Data Connection: Disconnected"

So the router was receiving a signal (albeit very low) but still gives "Data Connection: Disconnected". This is an issue I have observed previously with another router. All settings are correct, the router has signal but "Data Connection: Disconnected" remains. My research has led me to similar issues posted here:

https://community.teltonika-networks.com/880/mobile-data-status-disconnected

https://community.teltonika-networks.com/1215/issue-with-mobile-connection-using-contract-sim-and-static

Both cases seem to occur with data-only sim cards (same as we are using). Apparently the WAN does not receive an IP address? I have tried applying the suggested fixes via CLI but was not successful.

I tried several fixes: reregistering mobile connection, restart mobile connection and reboot modem. In the end I rebooted the router but this did not fix the issue.

At least for half an hour. About an hour later I checked the router again and got a "Data connection: connected" in the interface and a working connection.

Now three hours later (and back home), the router is offline again. This issue is puzzling and honestly becoming a serious problem for us. Any help is appreciated.

I wanted to upload the troubleshooting file but could not find the file upload function.

Please log in or register to answer this question.