11315 questions

13487 answers

21158 comments

31580 members

0 votes
121 views 0 comments
by
Hi,

I need to make a TRB140 configuration bash script to prepare couple of hundreds of those units. The first step is to change a password for admin and choose skip wizard option. I run passwd command and it changes the password effectively, but when I enter WebUI it asks me to change password and starts a configuration wizard. How can I prevent it? I've tried to determine which files have changed within the filesystem after I choose to skip wizard, but it seems that the affected files are not within /etc folder, they are stuck somewhere else. I tried to check it - but find -mtime command only takes days as a parameter, and I would like to check which files in entire filesystem have been modified last minutes to check them. Do you know where the information that the wizard does not need to start is located?

Thanks in advance

Krzysztof

1 Answer

+1 vote
by

Hello,

The first time login setting on the latest RUTOS (7.x and newer) firmware is in the "vuci" file at /etc/config/vuci. The following lines needs to be set to a value of 0:

option firstlogin '0'

After making the change it is necessary to reload the "vuci" service by issuing a command: /etc/init.d/vuci reload

If your script executes specific commands via CLI (SSH), you can include the following commands in your script to make sure the first time login procedure never happens. I've also included the option for advanced mode to be enabled by default but if you do not need it you can simply remove the line for the advanced mode:

uci set vuci.main.firstlogin='0'

uci set vuci.main.advanced='1'

uci commit

/etc/init.d/vuci reload

Alternatively, all of these commands can be executed in a single line:

uci set vuci.main.firstlogin='0' && uci set vuci.main.advanced='1' && uci commit && /etc/init.d/vuci reload

Let me know if this works for you. Also, please note that the path to the file with first_login setting is different on legacy firmware - it's at /etc/config/teltonika.

Best regards,

Tomas.