10936 questions

13039 answers

20337 comments

27545 members

0 votes
174 views 3 comments
by

Hi

We recently upgraded RUT240 to firmware 0.7.01 and notice significant drop in speedtest. We get ~43Mbps out of 100Mbps. We have another unit still running on old firmware 00.01.14.3, and the result is better ~95Mbps. Please advise.

1 Answer

0 votes
by

Hello,

You need to upgrade to the latest version of RutOS 7 (07.01.2) and repeat the tests:

https://wiki.teltonika-networks.com/view/RUT240_Firmware_Downloads

If possible do not use "Keep settings" or reset device once again.

Best regards.

by
Hi,

We managed to get better result after device reset. However it start to show same issue again after we added new packages/configuration:

Here are the results after each changes (in sequence).

1) Device Reset
Speedtest result (70-80 Mbps)

2) Install SNMP package
Speedtest result (50-78 Mbps)

3) Install QOS package
Speedtest result (38-63Mbps)

4) Add IPsec configuration
Speedtest result (45 - 61)

Is there anyway we can improve this?
by

The RUT240 does its best with its system characteristics. 

Additionally you can enable NAT offloading via Web Ui Networks > Firewall page. The Routing/NAT Offloading is used to turns software flow offloading on or off.

The device checks whether the flow (sequence of related packets) is of a received a packed is known. Packets of unknown flow are forwarded to the networking stack. Meanwhile, if the flow is known, NAT is applied (if matched) and the packet is forwarded to the correct destination port. This process is called software flow offloading.

Regards.

by
Hi Sarunaska,

We able to get 92Mbps after enable the software flow offloading. Thanks for your advice

Regards,