10894 questions

12980 answers

20232 comments

26384 members

0 votes
246 views 10 comments
by
HI All

I have an issue with the https/http server settings, there is an option for delay which i thought was a delay between sending data to the connected server but no matter what value i put in it just constantly sends data, is this a bug or am i doing something wrong?

Paul
by
Hi,

I now have :-
 

root@Teltonika-RUT955:~# uci show gps.https

gps.https=section

gps.https.enabled='1'

gps.https.hostname='***********************'   < Blanked out for security

gps.https.delay='240'

gps.https.interval='240'

But its still sending every 5 seconds
Is that correct?

1 Answer

0 votes
by

Hello,

Could you tell me what HTTP server you were using, since if the server cannot send back an acknowledgment message to the router, the period will always be 10 seconds since router tries to send data again, because for it, it looks like is has not reached the destination. 

Could you try to test your solution with https://beeceptor.com/ and see if the data comes on the set period. To test it, just enter some name, press create endpoint, copy the first link and paste it into data to server URL field.

Regards,

Paulius

by
HI

ok set that up as suggested

https://beeceptor.com/console/dream2

delay is set to 60 seconds, you will see that its sending every 5 seconds

Paul
by

Could you tell me, what kind of information you were trying to sent via Data to server functionality?

Could you then attach troubleshoot file, you can do that via WebUI System -> Administration -> Troubleshoot and then press download in the troubleshoot tab. You can find the detailed instructions in our wiki. The file if will only be seen to Teltonika engineers.

by

Hi,

Screen shot attached of the configuration, its simple just the gps location.

Even though its set to 60 seconds it actually sends every 5 seconds  the delay figure does not seem to change the send delay.

Paul

by
I can not see any way to attach the trouble shooting file?

Paul
by
To upload a file you need to click the insert link button, then go to the tab called send, upload the file, the site will generate a link for that file and then just go back to the first tab, enter the text for how will the link will be displayed
by

There currently is a firmware issue that incorrectly inserts the name for delay option into configuration file from WebUI. The issue will be resolved in the upcoming firmware versions.

For a temporary solution, to set the delay you want, you can use uci commands from routers CLI. You can find the connection methods here.

After logging in, input the following commands:

uci add_list gps.https.interval='<any interval>'

uci commit

This will then make the HTTPS server to send data on the set interval instead of the default 5 seconds.

If you want to change the interval at any point, you will need to use another command:

ucit set gps.https.interval='<any interval>'

ucit commit 

Regards,

Paulius 

by

Hi,

I now have :-
 

root@Teltonika-RUT955:~# uci show gps.https

gps.https=section

gps.https.enabled='1'

gps.https.hostname='***********************'   < Blanked out for security

gps.https.delay='240'

gps.https.interval='240'

But its still sending every 5 seconds
Is that correct?

by

Hi Paulius

Any other suggestion on how to make this work

Paul