10456 questions

12460 answers

19384 comments

21896 members

0 votes
198 views 4 comments
by

hi

I have disconnections from the modem 2 to 4 times a day without reconnecting! I have to force "register" for it to work again. Annoying ! 

Information No. 1: when there is a disconnection, the status LED changes from red -> yellow -> green, then red -> yellow -> green again, cyclically indefinitely. 

Information N°2: This does it with an old firmware in 06.07.7 as with the latest firmware 06.08.6 

Information N°3: same problem with two SIM cards from two different operators.

Here is the product information:

Router name

RUT950

Host name

Teltonika-RUT950.com

Router model

Teltonika RUT950 LTE

Firmware version

RUT9XX_R_00.06.08.6

Kernel version

3.18.44

Product code

RUT950GG12K0

Batch number

0032

Hardware revision

0808

Modem

Model

LE910-EU V2

FW version

20.00.402

I attach the file "trouble_backup-Teltonika-RUT950.com..." but file "tcpdebug-Teltonika-RUT950.com..." is too big to be transmitted 3.5mb   The problem starts at 1h17m12s

Who else can I do to help you with debugging?

Best regards

Laurent

by
at 1:29 p.m. there was a disconnection but it went away on its own 2 minutes later. I can't attach a new damage file, but I have it.

I am connected to the internet with the modem but the status LED flashes red but there is no network. The signal quality LEDs are 4/5 green

It can happen that the status LED is green but only after reconnection to the network or modem.

1 Answer

0 votes
by

Hi,

I have the same legacy design device and from my experience the modem becomes very unstable with "recent" firmwares (RUT9XX_R_00.06.07 and newer).

Can you downgrade to FW RUT9XX_R_00.06.06.1 and see if the problem is solved?

Here is what I posted earlier on the forum:

https://community.teltonika-networks.com/44072/rut950-modem-timeout

by

Hi

Thank you for your advice 

With version 00.06.06.1 no connection. Works with 00.06.07 but I got disconnected last night. The green LED flashes every second. Which corresponds to: no data session established

I'm still waiting a day to see how soon I'll have the problem and then I upgrade to the next version until I have a stable version. 

And on your side, did you find a solution to your problem? 

by

Hi,

I did not quite find the solution to my problem - all I know is that starting from FW RUT9XX_R_00.06.07 to the latest FW available the communication with the modem becomes unstable. I'm using logread -f in console to monitor the device and from there it can be seen that the modem is not responding to AT commands (it seems to hang after command AT#NCM=1,1 is sent to the modem) and is unable to recover from this:

10:53:12 2021 daemon.notice netifd: ppp (18978): Connecting modem

10:53:12 2021 local1.info gsmd[17812]: gsmd send: 'AT#NCM=1,1' (11)

10:53:12 2021 local1.info gsmd[17812]: gsmd get: 'OK' (2)

10 10:53:12 2021 daemon.notice netifd: ppp (18978): OK

10 10:53:18 2021 user.notice NCM.SH: ppp_4: Connection state: Timeout.

10 10:53:24 2021 user.notice NCM.SH: ppp_4: selected IP:

10 10:53:30 2021 daemon.notice netifd: ppp (18978): Timeout.

From the GUI (luci) under Status>System when temperature is shown as 'N/A' or on the overview page you see Timeout. being displayed then this is also a tell tale sign that the modem is not responding to AT commands. With firmwares starting from 00.06.07 I get that a lot. From monitoring the device logs I can see there is some modem_check script which is sometimes able to reset the modem but it doesn't seem to be running all the time.

I checked the ncm.sh scripts between releases 00.06.07 and 00.06.08.6 and they are identical. In release 00.06.06.1 the script is slightly different. Coincidence? Could it be that the newer firmwares are not properly tested on legacy devices which are using a different modem?

Which connection mode are you using? In case you are using NCM you could try switching to PPP to see whether that makes a difference and I would also suggest enabling ping reboot.

by

Hi

Thanks for you answer

I use NCM or PPP but it's the same problem. I tried multiple versions but still the same problem. (old as recent). 
And for two different modems the same problem. I think there is no solution, there is a problem in the modem or it works better in another country. 

How do you do a ping that reboots the modem?