FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12075 questions

14368 answers

22637 comments

36190 members

0 votes
482 views 13 comments
by
Hello,

I am having troubles in connecting to TRB140 via either ssh or webUI over OpenVPN.

It says "connected" as a status and it gets an IP under the vpn, but I still can't seem to access it.

Any advice for something I may be missing out?

Thank you in advance

1 Answer

0 votes
by

Hi, 

By default RUT firewall blocks access to ports 22/80/443 when trying to access it from zone different than LAN.

Have you enabled remote access via System -> Administration -> Access control

If you have remote access enabled, generate troubleshoot file via System -> Administration -> Troubleshoot and PM it, I'll take a look.

by
Nope. Problem is I have vpn client running on my linux PC + on Teltonika. Connection is stable and working on both devices. On server I want to ssh to client. I can ssh to my linux PC but not to Teltonika. As I wrote above I think issue is that opevpn connection don't have firewall rules for ping and ssh created (to be honest I don't know how to add them). Can I configure firewall on configuration page? I cannot find even in advanced mode. I'm sing FW version from 09.2021 TRB1_R_00.07.00.1 latest seems to be: TRB1_R_00.07.01.4
by

Correct. From Basic view you cannot configure the firewall to enable ssh over wan. To do this simply click on Basic mode and it will change to Advanced. Then you can review the rules by accessing via Network→Firewall→Traffic Rules. The ENABLE_SSH_WAN and ALLOW-OPENVPN-TRAFFIC options must be enabled. Here is a link with more information about the firewall configuration.

https://wiki.teltonika-networks.com/view/TRB140_Firewall#Traffic_Rules

You can also update your gateway firmware by going to https://wiki.teltonika-networks.com/view/Main_Page. Selecting the model of your gateway and then Firmware download. There you will also find the steps to follow to update it. It is always good to update it because each update fixes some past bugs. 

by
Both options are enabled I checked on webpage.
by
Have you tried updating the firmware? Although you say the interface is up and stable. Can you reach the virtual IP of the server? As I said, it is possible that the interface is up and stable but the vpn is not up as such.  Please, send me the logs to alvaro.navarro@teltonika.lt
by

Hello,

I was checking all the settings and options enabled. On the Teltonika router side everything is correct. I did some research on the common issues and found that it could be the configuration on your server. 

Here is a link with the same problem (Ping client to server, but fails to ping server to client). In this type of issue, although many times they say that it can be the firewall configuration. Enabling the remote access of ssh, http and telnet, is enough to access the router. In this case, it was verified that a route on the server to the client was wrong. It could be your case also. 

https://forums.openvpn.net/viewtopic.php?t=21487

https://serverfault.com/questions/422439/openvpn-server-cannot-ping-clients

On the other hand, I leave you how to configure the TLS clients on the server, so that it can access the clients through its virtual ip or LAN. 

https://wiki.teltonika-networks.com/view/OpenVPN_configuration_examples#Clients_from_Server