10879 questions

12962 answers

20220 comments

26087 members

+1 vote
108 views 1 comments
by
Dear Team,

I try to set up a OpenVPN connection. The RUT240 is a connector and should connect to the OpenVPN cloud as unattended device.

I followed the instructions provided by OpenVPM.com and get a 'Connected' for some secondes, than it fails.

The troubleshoot file told me, that IPv6 has some problems. I checked every setting I found regarding to IPv6 nothing helps. I also checked the mobile connection, here I get a IPv6 address from my provider.

Now I dont have any idea whars wrong.

With best regards

Gerhard
by

Dear Team,

I am also in contact with OpenVPN and they send this comment:

Hello Team,

IPv6 is a requirement for the connection. You are receiving this error because IPv6 is currently turned off for your Linux.
Solution:

If you see 0 at sudo cat /proc/sys/net/ipv6/conf/all/disable_ipv6 that means you have it enabled, if you see 1 you can enable it by pressing the sudo sysctl net.ipv6.conf.all.disable_ipv6=0 command.

Let us know the results.

Kind Regards,

Gabriel Palmar
Technical Support Team
OpenVPN Inc.

Is it possible to do this on RutOS? Or whats the correct commands to get it working?

With best regards

Gerhard

1 Answer

0 votes
by

Hello,

Thank you for contacting.

Please refer to the following :
https://community.teltonika-networks.com/26900/rut240-ipv6-support-mobile-network#:~:text=1%2C%20you%20need%20to%20enable,%3E%20LAN%20%3E%20General%20Setup%20page.


You can enable IPv6 in the Interfaces you are using.

Thanks