10879 questions

12963 answers

20221 comments

26137 members

0 votes
126 views 0 comments
by

I ran into a possible firmware bug with RUT9_R_00.07.01.2 where the GPS stopped working one day. The map view said 'No GPS signal' and gpsd returns

[gpsd_ubus_init:89] error: Failed to add object: Invalid argument[nmea_init:609] error: Failed to initialize GPS ubus

[main:99] error: Failed to open the gps device for NMEA reading

However, I get valid NMEA messages if I run

dd if=/dev/ttyUSB1

The issue was 'fixed' when I upgraded to RUT9_R_00.07.01.4, but this is not mentioned in the changelog at all, so I assume it has not fixed the root cause. Perhaps it is possible that the firmware gets confused if the serial port changes for some reason. It is obviously impractical to flash firmware if this issue happens again, so I would appreciate if the devs could look into this.

Thanks.

1 Answer

0 votes
by
Hello,

Not every issues solved is written into the changelog file as sometimes the issue was related to when other issues were solved, this got solved as well.

Regards,

Paulius