FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12012 questions

14294 answers

22535 comments

35936 members

0 votes
2,983 views 8 comments
by
Hi,

I have a problem.....

Router:               RUT240

Configuration:     LTE Connection, OpenVPN Client Connection (working)

All Traffic of the WLan/LAN IF is routed throu the VPN tunnel..... workes fine.
But when the VPN connection brakes, the routes of the RUT240 will not be resetet, and the RUT240 tries to route via the VPN which it not there.

If the IP of the VPN Server is changed (Dyndns) the RUT240 is no longer able to restore the connection, because it can not send any data to the new IP because it´s routed to the broken VPN.

Someone an idea how to solv this problem?
by
I still have this problem.. when any one of the side is rebooted, the VPN fails.  Can anyone help.

3 Answers

0 votes
by

Hi,

Have you set keep alive in OpenVPN?

Also you could try to enable Ping reboot which will automatically restart mobile connection when internet will be lost.

0 votes
by
Yes keep alive is activated .... the RUT240 tries also to reconnect, but the IP has changed in meanwhile. And the routing table shows still that all traffic has to be routed to the VPN IF which is not up in this moment.

Ping Reboot is also activate but it is only a small workaround, it´s slow, needs traffic, and is no realy fallback. When the VPN client detects a broken connection, it must also delete his routes.
by
Try to reinstall router firmware (https://wiki.teltonika.lt/view/RUT2xx_Firmware).

DO NOT keep settings when flashing!

If issue persist, send to me troubleshoot package from router when issue appears.
by
I have flashed the newest firmware yesterday .... so it should be ok ...

How can I send you the troubleshoot data?
by
Press on my user and send direct message.
0 votes
by
Try to use only Mobile as WAN (Network -> WAN), and check then.
by

Not realy better.... routes are still there ...

Test 1: I configured "Auto Reboot" to ping the internal IP of my Tunnel (10.164.31.1) and to restart the mobile connection if two attemps are faild.

Connection is restarted automaticly, but routes to VPN are still there ....

Test 2: I configured "Auto Reboot" to ping the internal IP of my Tunnel (10.164.31.1) and to restart the modem connection if two attemps are faild.

Connection is restarted automaticly, but routes to VPN are still there ....

Test 3: I configured "Auto Reboot" to ping the internal IP of my Tunnel (10.164.31.1) and reregister connection if two attemps are faild.

Connection is restarted automaticly, but routes to VPN are still there ....

Test 4: I configured "Auto Reboot" to ping the internal IP of my Tunnel (10.164.31.1) and reboot if two attemps are faild.

nothing happens ;-(  ....

Test 5: Hard reset (power lost) + VPN Server down/not reachable

routes are gone   ....  Internet via Mobile GW is possible ....  ---> VPN Server back up ---> Internet via VPN possible ----> Server Down ---> Routes are gone ;-)

---> Server back up ---> Internet via VPN possible ----> Server Down ---> routes are still there ;-(

Test 6: Hard reset (power lost) + VPN Server up/reachable

....   Internet via VPN possible ----> Server Down ---> Routes are stil there... ;-(

 
I also found out that the NTP Deamon sets the time wrong .....   2019-03-21, 03:37:49 but it is 2019-04-01, 22:00:00     after Sync with the Webbrowser the time is correct, but on the next NTP sync it is wrong again ;-(

by
Hi,

Seems like something went wrong with router software. Could you try to reinstall router firmware one more time.

DO NOT keep settings when flashing!

After install, reconfigure only OpenVPN.
by
hmm... I tryed it again, with no result .... but after a reste via the reset button, it seems to work now....  I will do some aditional tests later....

Maybe you can also answer me the question how I can deactivate that all traffic is been send thru the VPN ... I want only have some static routes which should go thru the tunnel...

Thanks for the great support!
by

Maybe you can also answer me the question how I can deactivate that all traffic is been send thru the VPN

This is made on server side, not on client: https://wiki.teltonika.lt/view/OpenVPN_configuration_examples#OpenVPN_Proxy