subscribe to our Youtube


14142 questions

16797 answers


54015 members

0 votes
576 views 3 comments

      I have a Rut240 on Verizon that I set up to use with a Helium miner Bobcat 300.  I followed the Teltonika Wiki and everything worked fine. I have port 44158 open through my VPS to the Bobcat device.  However like many Teltonika users but it still shows as relayed.  According to Bobcat it is because there is still NAT enabled and that it is a Teltonika issue.  I have read everything I can find on this matter.  So far I can not find a definitive solution for this.  I am disappointed that Teltonika has not done more to address this.  Teltonika sends you to Bobcat and helium and Bobcat send you back to Teltonika.  I do not wish to play customer ping pong with Teltonika anymore.  please help me resolve this issue.  If it cannot be resolved I need to return the 2 rut240's ASAP.  As far as I am concerned they are defective.  A product is only as good as its customer support.  Clearly verifying the port is open to the router must not be the last step,  Teltonika should be able to shed light more clearly on this issue given they are more than capable of clarifying this issue.  People are settling for relayed miners because they have already invested the money in the Rut240 and its taken to long to figure out it doesn't work and it is to late for them to return it.  luckily  I bought mine from Amazon so Teltonika will be getting mine and my friends Rut240s we purchased back as defective.  If Teltonika fails to answer this issue in a more definitive way that leads to a solution  then I recommend everyone do the same before you are stuck with a device that does not work for this application. I also recommend Teltonika put a clear disclaimer on the product stating that it is not a suitable device for use with Helium miners.  Please shed some light on this issue as I like the Rut240 but must source a replacement asap. I and many others have already invested more time into this than should be necessary.

Thank you


1 Answer

0 votes


I've taken a look at your issue online and it seems that while for some people the method, described on our wiki article worked perfectly, for others it is necessary to configure a full-tunnel to route all traffic through the RUT240s WireGuard tunnel to the VPS. I'm not entirely sure if this is the solution but could you please try to do the following:

  1. Login to the router via WebUI, navigate to Services > VPN > Wireguard
  2. Edit the main Wireguard interface, then edit the peer
  3. In the "Allowed IPs" field, instead of "", enter the following values: "" and ""
  4. Save & Apply the peer settings, then Save & Apply the general Wireguard settings

After performing these changes I'd strongly recommend restarting the router as well as the Bobcat. Once done, it may take some time for the status to change but it should change eventually. Let me know if this works for you.

Best regards,




This suggestion of changing allowed IP's did not resolve the issue.  Making the change resulted in port 44158 changing from open to closed.  I also would not allow web traffic.  The router did show connected to the verizon network,  however you could not reach websites through the browser and the only way I was ableto chec that port 44158 was still open was using another device.  I changed back to "" and internet operation returned to functioning and the port 44158 opened once again.  The device however remains relayed.  Nat  type is now showing symmetric,  I have seen nat type symmetric, restricted and unknown however I still have yet to achieve Nat type NONE.  

One observation I have made that might be a clue is the Bobcat miner's json file that can be run from the diagnoser shows that my private IP has port 22 and 44158 open, then it shows my public IP as both ports closed.  The issue I see here that I am not clear on how to resolve is it is showing my public IP as my current local IP the very same IP I see if I open another browser a go to "whatsmyip".  It does not show my VPN public IP which is what I think should be shown as my public IP.  I am clearly missing something here I have completely removed my linode an reset the rut240 and rebuilt both from scratch according to the Teltonika Wiki 3 times now and each time I have been successful in opening port 44158 through the Wiregaurd VPN but always have a NAT type other than "NONE".  Bobcat and Helium have not been able to help and point to Teltonika because the NAT is being Manipulated in the router.  The Wiki Ignores the NAT loopback setting and fails to mention it.  It is on by default.  I am currently on firmware version RUT2_R_00.07.01.4 .  this is the most current version I believe. So far I have been working on this for over a month and I am ready to try another device I will dispute my credit card charges as this device is unable to do what it should be able to do.  Apparently it is working for some however it is not working for to many buyers.  I cant believe that this is not an issue that is resolvable.  But I am running out of patience and time, the discord's I have searched have people offering solutions that have yet to work and were usually the cause of needing to reset the Rut240 and start over with a fresh Linode.  This is why I am turning to Teltonika to resolve this issue.  


To address this concern:

It does not show my VPN public IP which is what I think should be shown as my public IP

It's working as intended. The VPN tunnel is required to make the port "open" from the internet but it doesn't/shouldn't impact the default gateway in any other way if you're using the configuration provided on our wiki page.

The alternative solution would be to push all of the traffic through the Linode VPS and then out to the internet which would mean that your external IP address would end up being not the current external IP which is provided by your current ISP but the external IP address of Linode. This is effectively what was supposed to happen by issuing the commands above and it did seem to work on my end so not sure what went wrong in your case. 

Could you generate and send me a troubleshoot file and share the configuration from your Linode VPS at /etc/wireguard/wg0.conf and then send it over to me via private message? I could investigate this issue and possibly setup a simulation of how things are connected and configured exactly. Please make sure to sanitize the sensitive information from wg0.conf file (private WG key/public IPs) on VPS before sending it to me.

What's a troubleshoot file and how to generate it?

A Troubleshoot file contains the device's event logs, configuration files and other information useful for diagnostics. It can be downloaded from your device's WebUI, Troubleshoot page:

System → Administration → Troubleshoot


I sent the troubleshoot file and the VPN configuration. Or at least I attempted to send it via email.  I am not sure if you received it, it has been nearly a week.  please advise