10879 questions

12963 answers

20221 comments

26145 members

0 votes
116 views 3 comments
by
Hi,
I have an OpenVPN server (another brand) and an OpenVPN client (RUT240) both running on a local site (Which means both IP are in the same subnet because both are connected to WIFI). If I did not enable the OpenVPN client on RUT240, the RUT240 was able to ping the OpenVPN server, but when I enable the OpenVPN client in order to establish the OpenVPN connection, I was not able to ping the OpenVPN server already. Not only the OpenVPN server, other devices that are in the same subnet (which are all connected to WIFI), and the RUT240 are unable to ping successfully.
by
Then I used the command "logread -f", and it showed "Recursive routing detected, drop tun packet. Write to TUN/TAP : Invalid argument ( code=22)".But when I check the OpenVPN status in RTU240, it showed connected. But the RUT240 (client) is still unable to ping the Server.

1 Answer

0 votes
by
Hello,

In this particular situation issue might be related with conflicting/overlapping network IP ranges. Please share a topology scheme of your solution with IP addresses, so that it would be possible to check if issue is not related with networking aspects.

Also, could you clarify why do you want to establish VPN connection between two devices, which are already locally connected with one another? Maybe this is done just to show proof of concept, while in the future VPN would be used to connect two remote sites together?
by
Hello,

Thank you for the topology. What is your Robustel device's LAN network?

Since this is a testing device, maybe you could also share screenshots of both of your device configuration?

Also, have you enabled "redirect gateway" option on your Robustel gateway, to direct all traffic from RUT240 through OpenVPN? If yes, please disable it, since in this testing topology that might cause device connection issues.
by

Hello,

Your Robustel device must have a LAN network. If it indeed does not - than you cannot establish VPN from it, since VPN in general in meant to connect to remote networks together. If there is no network - VPN would not work. However, since your Robustel has VPN configuration, it must have LAN network as well, but it simply might be hidden from basic menus.

From your screenshots I can see that there is conflicting configuration:

  • Your Robustel device is configured to listen to its own WAN IP address
  • MTU is set to 1500. Depending on the situation, that might cause communication issues. For testing purposes try to use lower MTU, e.g. 1400
  • On RUT240 you have specified that remote network is same, are remote host network. Such configuration would indeed cause networking issues on your RUT240 device.

My suggestion in this situation: remove Robustel as a variable and for your first OpenVPN tunnel try to use two Teltonika device. That would have an advantage, since we have detailed configuration example for our devices, which you would be able to follow and avoid configuration errors. After making few successful VPN connections using instructions you would have general idea what settings are most important and what values they suppose to have. Then you would be able to experiment using any other equipment, which might not have instructions. OpenVPN configuration example how to create tunnel between two Teltonika devices can be found here:

https://wiki.teltonika-networks.com/view/OpenVPN_configuration_examples

Meanwhile, if you would like to find out more information about OpenVPN in general, here you can find very good official OpenVPN community article, which explains all OpenVPN details, from configuration nuances to troubleshooting steps:

https://openvpn.net/community-resources/how-to/