subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
356 views 4 comments
by anonymous


We deployed a RUTXR1 with a TXO 1G 1310nm 10km SFP module ( in a datacenter and configured static WAN IP details given to us by the provider. All other WAN settings were left at factory standard. We have installed firmware version RUTX_R_00.07.01.4. The fibre appears to be operational and light is coming through but we are not getting a link to the remote end. The WAN interface remains off (no lights) and there is no RX/TX activity. To rule out defective hardware, we tried a second backup RUTXR1 and a backup SFP module but we are seeing the same behaviour with all the hardware.

Whist we are working with the connection provider to resolve the issue from their end, would you have any ideas why we may not be getting a link to the remote end? Do you recommend a particular brand of SFP transceiver to be used with the RUTXR1?


1 Answer

0 votes
by anonymous

In theory, the SFP port should work with any standard SFP (SFP+ not supported) adapter.

However, if the adapter has some changes for compatibility sake with some other device, in this case I see that the SFP if compatible with Juniper devices, maybe they have some hardware changes required.

Maybe the SFP adapter does not report that it has a device connected to it, as that job now falls on the SFP adapter, to relay if the link is up or not.

Have you tried any other SFP adapters with RUTXR1?
by anonymous
Thank you for your reply, we have tried one other make of SFP transceiver but we had the same problem - no link.
by anonymous

Could you then do this:

  1. Shut off the device
  2. Pull out the SFP
  3. Power it back on
  4. Try to insert the SFP
  5. Connect the fiber cable
  6. Disconect the fiber
  7. Disconet the SFP
  8. Then access router's WebUI, go to SYSTEM > ADMINISTRATION > TROUBLESHOOT section, download troubleshoot file from there and send it to me
I will then try to see if there is any activity in the logs
by anonymous
Thank you, I currently only have remote access to the RUTXR1 via a 4G connection. We will attempt to get a technician into the datacenter again next week if our resolution attempts with the datacenter provider are fruitless and we cannot get a link. Then I will follow the procedure steps above and send you the troubleshoot files via a direct message. Thanks for your help!
by anonymous
We were able to resolve this problem by swapping the SFP and using the exact same vendor/type as the one used by the service provider at the remote end. Also speed on the remote end was forcefully set to 1Gbps auto-negotiation mode. We now have a functional link. Perhaps this information can be useful for anyone else having a similar problem.