11381 questions

13558 answers

21243 comments

31841 members

0 votes
89 views 1 comments
by
Hi,

One of my older RUT955 routers which is installed in a vehicle sometimes takes a lot of time after start-up or after briefly loosing and regaining GPS signal (eg. a tunnel) to start sending data to the AVL server. It is not a GPS fix problem since I can immediately see the correct position in the web UI, it's just not restarting sending it.

Given the fact that I found this thread with a similar problem - https://community.teltonika-networks.com/5802/gps-of-rut955-stops-sending-avl-data-randomly suggesting it has been fixed in a firmware update and that I see other weird behaviour with this unit (eg. VERY slow loading admin pages compared to other 955s, even though the wifi performance on regular web browsing is normal), I decided to try updating it.

I tried the 2022 built RUT9_R_00.07.01.4 but it failed verification, probably because it is an older model router and the notes on the release page say „FW version RUT9_R_00.07.00 and above will not be supported on legacy-design (RUT955 *7V***) devices.”.

Then I tried the RUT9XX_R_00.06.08.6 (upgrade over the currently installed 00.06.02) and weirdly enough it says „Uploaded firmware image version is OLDER than current firmware version. All configuration files will be erased.” That is obviously wrong since the router is running 00.06.02 from the factory and obviously it is older than the 00.06.08.6 I was trying to flash. I did not go through with the update since I do not really want to loose my config. I have a „config only” backup but I am not sure uploading that afterwards would work since there's this discrepancy.

Is there any way I can solve the GPS issue on the old firmware or upgrade without loosing my config?

Could it be the case that the firmware image fails to upload because of the horrendous performance of the web UI and the upgrade page I am getting is actually using an older file...? (that wouldn't really make sense since I also uploaded the 07 version which was rejected before this bogus „older image” message hit me when uploading the latest factory release from Teltonika for upgrade).

When I get my hands on this unit again I'll try a CLI upgrade but until then I'd like to hear your thoughts on this situation. Thanks!

1 Answer

0 votes
by

Hello,

You are indeed using a really old firmware. Due to this fact, many changes have been implemented since then and upgrading your device to the current latest legacy firmware version is not possible, while maintaining your current configuration. It can be achieved by first updating your device to the version RUT9XX_R_00.06.07.7, which can be downloaded from here. Then, once the update finishes, you can update to RUT9XX_R_00.06.08.6 without loosing your configuration.

Keep in mind that after the update some configuration changes might still be necessary due to many developments between firmware versions for the device to operate the way you desire, thus it is advised to make a backup file before performing any updates.

Best regards,

Žygimantas

Best answer
by
The 2 step upgrade process worked and also solved my GPS issued.

Thanks.