subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
174 views 3 comments
by anonymous

all of the settings i try to change in the WebGui wont save, meaning after a restart the old setting is active. Also the troubleshoot-file is not reachable.

I expect this occurs because the flash is nearly full, because i save the troubleshoot file in there (to have it after a restart)

Is there a way to erase the logs from the flash? Or free parts of it elsewhere so at least i may change the settings again?

Thank you!

1 Answer

0 votes
by anonymous


The log file is stored in the /usr/var/log directory in a file called messages. Check if that is not using too much space.

Best regards,


Best answer
by anonymous
Thank you a lot!

I could retrieve the message file, it has 20 Mb which even exceeds RUT240s flash of 16 Mb.
It also shows that the newest log is some weeks old meaning it doesn't get updated.
Problem now is that i can't remove the message file, cause file system is read only.

rm messages gives: can't remove 'messages': Read only file system
Is there a way to delete this file? And would this be clever, perhaps this would only cause other bugs?

I checked also if i could change settings by uci commands, but doing a uci commit only gives:
uci: I/O error
So this behaves like changeing settings over webgui, meaning no change after restart.

Best regards
by anonymous

You can try copying files to your PC using WinSCP if you are using Windows. The application can be downloaded from there:

For further details on how to dawonload files from Teltonika devices, please refer to this page:

Best regards,


by anonymous
Thank you for helping Zygimantas,

i copied the logfile to another pc.

I was searching now for a way to be able to set settings again, as my guess was that the full flash prevents this, i need a way to delete the big logfile.

Found this post which solved the problem:

I cleared flash by removing: /overlay/upper/usr/var/log/messages in RutOS
then i did a reboot and could disable "save troubleshoot file in flash" (eg in WebGUI) afterwards.
Setting settings works now finally.

Seems like RUT240 has a problem with deleting old logfiles when new ones are available, when saving them in flash.
And also with full flash generally.
Was on FW: RUT2XX_R_00.01.14.5.