subscribe to our Youtube


13306 questions

15793 answers


50164 members

0 votes
409 views 2 comments
So I'm trying to redirect all traffic from my teltonika over openvpn to my pfsense router. At the moment I'm running a shared key peer to peer setup. Status says both connected in RUTos and I also see the router showing up in pfsense with both it's public ip and it's virtual ip. But no traffic is going through it. When looking up my IP it's still that of that public IP on the teltonika so nothing is beeing routed through.

I also tried running a remote access setup and got that one to connect as well. Status connected in RUTos and both public and virtual ip showing up in pfsense. With this setup I'm guessing the teltonika is trying to route all traffic but failing as I loose all internet connection and all devices connected. Whats weird is that I can access the pfsense settings through with this setup. I also know that it is configured correctly on the server side as when I connect with my phone or computer as a client everything works just fine and the ip of the pfsense is showing then connecting the phone or computer through teltonika (the teltonika has all vpn settings turned of when trying this).

What am I missing? I'm happy with getting ether one of these setups working at this point

1 Answer

0 votes

Hi, check if there is such a line in the settings -

on client (teltonika) redirect-gateway def1

on the server (pfsense) push "redirect-gateway def1"

If these lines do not exist, then you need to add them. 

Accordingly, the difference if added only on the client, then it will affect only one client, if added to the server, it will affect all clients.

Best regards, Anton.

Thank you for answering. I had tried adding push "redirect-gateway def1" in pfsense but that did nothing. But never directly in the teltonika (without push). This seems to have worked and the router is now trying to push traffic over the VPN but no traffic is going over. There is no internet connection at all on the teltonika now. I tried pinging the pfsense router but got nothing back. Also as I said earlier when I tried this directly on my computer it worked so the pfsense should be configured correctly.

Am I missing some kind of firewall settings or routing or something else that is blocking my connection?

I have so far tried adding and interface for the VPN just called VPN that i assigned to tun_c_testvpn in physical settings and the interface says running but I am not sure of how to route the traffic.

Hello, I'm using Pritunl server and I don't have any problems with the configuration. I downloaded the configuration file, uploaded it to the router and all traffic goes through the VPN.

Zones and rules in the Firewall are created automatically, the screenshot shows the settings without manual changes.

Traffic Rules section

Probably adding this line to the server configuration can also help - push "remote-gateway vpn_server_ip"