10432 questions

12435 answers

19335 comments

21799 members

0 votes
63 views 5 comments
by

Hi there,

I'm trying to monitor the WAN IP of a TRB141 using the data to server option via HTTP but I can't get it to work. I have successfully done it on a RUT240 and I can't figure out what's wrong on the TRB141.

Here is my setup:

Note that I have tested the webhook with postman successfully.

Thanks for your help

1 Answer

0 votes
by
Hi,

As I can see from the screenshots, You haven't defined anything in the JSON format. Please enter the below string in the JSON format:
{ "Data" : "%a"}

Check if you get the data successfully.

Regards,
Ramandeep
by
Right.... I didn't realise it was only the placeholder.

I entered {"data": "%a"} but still not working. I tried {"data": %a} too. Any other idea?
by
Hi Jules,

Did you enable Modbus TCP Slave on TRB141?

Try to disable the option "Send as Object" and change Data filtering to "All data". Make sure that URL/HOST/Connection String is correct. Save and apply. See if you get the data on the server.

Regards,

Ramandeep
by
Hey Ramandeep,

None of that worked but I started receiving data by changing parameters back and forth...

At the end parameters match the screenshot above and it works. Not sure what to think...

Cheers

Jules
by
Hey Jules,

Great to hear that It worked for you.
Where did you change the parameters? On Data to server or Modbus Master configurations?
by

Hi Ramandeep,

I only played with the data to server settings, as you can see on my initial post I was able to read the registers from the device, so I assumed the master and slave configuration were working fine.

Below are the working parameters, and as you can see I didn't change a thing.