10857 questions

12933 answers

20166 comments

25486 members

0 votes
69 views 4 comments
by
I have an RUT950 with firmware RUT9_R_00.07.01.4  which is connected as a client to my home WiFi network. If I disable the mobile interface then everything works as expected - the router uses the WiFi connection as the WAN. In the Failover configuration I have WWAN0 listed above MOBS1A1 so I understand it should prefer the WWAN over that. However if I enable MOBS1A1 in Failover then traffic goes via the mobile connection instead of WiFi. This is not what I expect.

The manual says there should be a Network/WAN section but this does not exist in my UI.

Some screenshots attached.

1 Answer

0 votes
by

Hello,

Thank you for contacting us. 

Your assumption is correct, the priority of WAN failover interfaces is based on their order in the Network interfaces section and failover menu. Thus traffic should be routed through Wireless WAN interface first, based on your configuration.

Based on your Status -> Overview window, WWAN is the main interface and should be used for internet connectivity. 

Your Network -> Interfaces window screenshot shows that Failover is disabled.

How did you test, which interface is used for internet connectivity?

Best regards,

Žygimantas

by
I test for connectivity using traceroute. I can see that Failover shows disabled for the WWAN but can't find a way to turn it on. I just tried deleting that interface and re-creating it, but it is now not offering wlan0 as the physical interface. I will try a factory reset and start from scratch.
by

"The WiFi password is located on the label". Well that's a really unhelpful place to put it, given that these devices are designed to be installed into stuff, not just sitting on a desk. Hopefully I took a picture of it before installing.

by
So yes, I did have a photo of the label, thank goodness. Things seem to be much better now after the factory reset, the WWAN is showing as Failover: Enabled and traffic seems to be going in the right place.

The WiFi seems slow though - I did find when using the RTU950 WiFi in AP mode it was slow, and now in client mode it is delivering around 4-5 Mbits/s even with a solid WiFi connection  (104/65 Mbits reported by the AP)  to the same network as my desktop, which is showing around 80 Mbits/s on a speedtest. I realise it won't be as fast with another WiFi link in the picture, but a greater than 10x speed difference seems a lot.

Another question - I have added multiple SSIDs for the WiFi client mode, and it seems each one appears in the interfaces and failover list as a separate interface, requiring individual enabling and ordering. Is this as intended?
by
Hello,

Nice to hear that your setup is working.

Regarding high Wi - Fi speed loss in client mode, there is a known issue, which is under investigation. However, no solution is available at the moment.

As for multiple SSIDs for the WiFi client mode, each new instance indeed creates a separate interface. Thus, device works as intended.

Best regards,

Žygimantas