FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12691 questions

15070 answers

24150 comments

47148 members

0 votes
469 views 3 comments
by

Hello,

I connected my RUT950 as a Wireguard client to my external cloud based Wireguard server.

The tunnel seems to be up and working:

root@Teltonika-RUT950:~# wg

interface: poland

  public key: /bAU/p546ZfZivG+oT3kOvdCc=

  private key: (hidden)

  listening port: 51820

peer: RM3v7AFb+tZN3XO0H9QS7/fu4WE=

  preshared key: (hidden)

  endpoint: <External IP>:51820

  allowed ips: 0.0.0.0/0, ::/0

  latest handshake: 8 seconds ago

  transfer: 92 B received, 180 B sent

  persistent keepalive: every 25 seconds

I made the following setting in firewall Zone section: wireguard=>wan 

But all clients connected to my router still have old ip addresses.

Seems the traffic is not routed to VPN tunnel.

What should I set additionally to route traffic to Wiregurd VPN tunnel?

Thank you.

1 Answer

0 votes
by

Hi adex1361,

Could you please confirm which firmware version your router is currently running? Also, please double-check the firewall zone. By default, wireguard  firewall zones should look like this:

https://community.teltonika-networks.com/?qa=blob&qa_blobid=16250684043947858077

On the other hand, I don't fully understand what you mean by saying: "But all clients connected to my router still have old IP addresses." So far, I can guess you have enabled the DHCP relay feature on the LAN interface, and you are trying to get IP addresses on your host through a DHCP server configured on your cloud-based wireguard server. If so, verify the DHCP server and DHCP relay feature are correctly configured. I will drop a link below where you can find how to configure the DHCP relay feature:

https://wiki.teltonika-networks.com/view/RUT950_LAN#DHCP_Server

For clarity purposes, it would be helpful if you could share the network topology of the implemented solution and the troubleshoot file of your device to take a closer look on your configuration.

I look forward to reading your comments.

by

Hello,

few days ago I migrated to RUTX12.

The problem with Wireguard is still the same for RUTX12 also.

My firmware version is RUTX_R_00.07.02.1

I think the problem is in routing tables.

When I connect over OpenVPN I have the following routing table:

 

where tun_c_poland is OpenVPN network interface

and 10.8.0.0/24 is my VPN network

When I connect over Wireguard I have the following routing table:

As you can see my Wireguard network interface ("poland" in my case) does not take part in routing.

This could be the reason why the traffic is not routed over Wireguard interface.

Do you have any suggestion how to correct this problem?

Thank you.

by
Hello All,

I was able to solve Wireguard routing problem with the help of

https://community.teltonika-networks.com/39990/configure-three-different-clients-route-different-devices

Thank you.
by
Hi adex1361,

I'm glad you could solve this issue by following some instructions from another query in the forum. If you need more help related to this topic or another subject, please don't hesitate to contact us. I hope you have a good day.

Regards.