10879 questions

12963 answers

20221 comments

26152 members

0 votes
167 views 8 comments
by

In accordance with the 3G shutdown here: https://wiki.teltonika-networks.com/wikibase/index.php?title=AT%26T_3G_Network_shutdown_information I have updated my RUTX11's to firmware RUTX_R_00.07.02.1

However, one of them is "stuck" and the modem fw did not update to the expected version (EG06ALAR02A07M4G)

The device is stuck at firmware: EG06ALAR04A01M4G

How can I get this device to update its modem fw? It does not seem possible via CLI, GUI or RMS... I saw mention about a /usr/sbin/quectelFlasher tool but my system does not have it. Nor anything in /tmp that resembles modem fw. Also, tried running `rut_fota --download_modem --debug` but it generates this error:

Starting communication with FOTA server
Connected to rut.teltonika.lt:5000
Connected with SSL
Sending buffer of size 213
[read_all:168] error: SSL read failed
[start_communication:120] error: Failed to retrieve command from server
[main:327] error: Communication has failed

Help please!

1 Answer

0 votes
by

Hello,

With 7.2 and above firmware versions you can use the modem updater tool:

There are instructions (CLI commands):

  1. opkg update
  2. opkg install modem_updater
  3. opkg install sshfs
  4. modem_updater -g (will parse device modems  with ID numbers and available firmware versions)
  5. modem_updater -i <ID> -v <VERSION>  Modify this based on the output of the last command (use the second modem ID and firmware version name you would like to install) 
Make sure that your router will have internet connection through other modem or Wired/Wireless WAN (not through the modem you are updating).

Regards.

by
Thank you for this! I will try it and report back.
by

@VykintasKuzma

Thank you for this help. But, I was unsuccessful. The modem remains stuck on EG06ALAR04A01M4G.

Here is the output:

root@RUTX11:~# modem_updater -i 3-1 -v EG06ALAR02A07M4G
[000.000]: Version: QFirehose_Linux_Android_V1.4.8
[000.000]: Builded: Aug 31 2021 22:20:08
[000.001]: P: /dev/bus/usb/003/011 idVendor=2c7c idProduct=0306
[000.001]: C: /dev/bus/usb/003/011 bNumInterfaces: 5
[000.001]: I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff
[000.001]: E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001]: E: Ad=83 Atr=03 MxPS= 10 Ivl=9ms
[000.001]: E: Ad=82 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: E: Ad=02 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001]: E: Ad=85 Atr=03 MxPS= 10 Ivl=9ms
[000.001]: E: Ad=84 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: E: Ad=03 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00
[000.001]: E: Ad=87 Atr=03 MxPS= 10 Ivl=9ms
[000.001]: E: Ad=86 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: E: Ad=04 Atr=02 MxPS= 512 Ivl=0ms
[000.001]: I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff
[000.002]: tmp=/sys/bus/usb/devices/usb3/../driver, driver=../../../../../../bus/platform/drivers/xhci-hcd
[000.002]: qusb_noblock_open port_name = /dev/ttyUSB0
[000.003]: old software version: EG06ALAR04A01M4G
[001.004]: poll_wait events=POLLIN msec=1000 timeout
[001.005]: switch to 'Emergency download mode'
[001.007]: successful, wait module reboot
ping: sendto: Network unreachable
[ERROR] internet connection is not active

Couple notes:

1) getting the "modem ID" was confusing at first because modem_updater has no direct command to list them. I figured out after closely looking that if you run it with no arguments, the modems are listed above the help text.

2) when I ran `modem_updater -g` it listed 2 available:

root@RUTX11:~# modem_updater -g
Available versions:
EG06ALAR02A07M4G
EG06ALAR02A07M4G_04

I tried both of them—not sure which is correct? What is the 2nd one for?
Thank you
by

Due to the [ERROR] internet connection is not active message, I am wondering- does this command only work when there's another WAN connection (Ethernet) active? Because in this case, the unit only has 4G connectivity. 

by
Hi,

You are correct, your device must have an internet connection through a wired or WiFi WAN while you are updating.

I would like to ask if you do use RMS with your devices? If you would allow me, I could try to update your modem firmware remotely (for that I would need the serial number and password of your device via a private message).

Regards.
by
Ok, I have sent you a PM. Thanks
by

Hello Vykintas,

Maybe you got busy, that's ok.

I connected my RUTX11 using Wifi client mode and was able to run the command. So I don't need you to connect via RMS anymore.

But, I would still like to know the answer to my other question:  what is the difference between these 2 firmwares? What is the _04 version for?

  • EG06ALAR02A07M4G
  • EG06ALAR02A07M4G_04

update: I decided to test them on my own, but it is not clear. After running the below commands, resulting firmware version is identical:

# modem_updater -i 3-1 -v EG06ALAR02A07M4G
[...]
# ubus call vuci.network.mobile get_all_modems | jsonfilter -e '@.modems[0].version'
EG06ALAR02A07M4G
# modem_updater -i 3-1 -v EG06ALAR02A07M4G_04
[...]
# ubus call vuci.network.mobile get_all_modems | jsonfilter -e '@.modems[0].version'
EG06ALAR02A07M4G
by

Just adding a comment here in case it helps anyone, apparently (according to this thread) actually EG06ALAR04A01M4G is the later/latest firmware. So all this time I am incorrect trying to "upgrade" it. 

In fact, now the question becomes, how to upgrade EG06ALAR02A07M4G to EG06ALAR04A01M4G...

by
I was able to obtain the new firmware from Quectel directly. I scp'd it to /tmp and then used modem_updater -i 3-1 -p /tmp to get the job done.