10879 questions

12963 answers

20221 comments

26145 members

0 votes
124 views 3 comments
by

Hello,

After the Update to Version: RUT9_R_00.07.02.1  the Router is not able to provide Mobile Data connection.

Same Sim Card, workde with the older Version. Modem is Disconnected. Tried the Auto APN didn´t work.

Donwloaded Troubleshoot

Why it is not showing a signal.

Please Help

by
One of ours did this.

(RUT955)

I had to visit the site it was located and dial in via Wifi to reboot the modem.

Was a 4 hour round trip.. costing £100 in fuel.

Other 6 devices, did not have the issue.

2 Answers

0 votes
by

Hello,

The troubleshoot indicates modem having issues with the SIM card. However, consideering that it had worked previously, I would like you to perform a modem firmware upgrade. Before updating, you need to have the device updated to at least 7.02 and connected to either wireless or wired WAN source. The procedure is as follows:

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - should be 1-1.4, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command.

Best regards,

Žygimantas

by

Hello,

Thanks for the answer. This approach helped me fix two RUTX11 modems which were stuck on "disconnected". However, I still have one RUT240 running on RUT2_R_00.07.02.1 which I cannot get unstuck. I have tried most (all?) modem firmwares avaliable from modem_updater -g. I'm currently on modem firmware version EC25ECGAR06A12M1G_BETA22042.

My situation is pretty annoying.

--

Wictor

by
Hello,

I suggest to not to use BETA versions, as these are designed for testing and verification purposes, and install EC25ECGAR06A12M1G instead.

Next, I would like you to generate and upload a troubleshoot file from the RUT240 device with the updated firmware.

Best regards,

Žygimantas
0 votes
by
Roll back to previous firmware, then works fine.