10503 questions

12508 answers

19436 comments

22021 members

0 votes
49 views 1 comments
by
Since for some reason the new bootloader (the one shipped on RUT955V03020 batch no: 117) no longer accepts OpenWRT images I would like to downgrade the bootloader to something like 3.0.1 or 3.0.10. Where can I find these downloads? I have looked all over the wiki.

Also I'd like to know why this was changed? It seems the bootloader tests the checksum or looks at the files.

/parsed

1 Answer

0 votes
by
Hello,

Teltonika devices are manufactured to be primarily operating with the Teltonika software and bootloader is also a component of this mindset.

In general, it is not recommended to change the bootloader software at all, and even in some individual cases it is only recommended to upgrade it, as there is a possibility to brick the device. Different bootloader version add new hardware support, which occasionally changes between the batches. Thus, the downgrade will most certainly result in device not being able to start properly without the possibility to recover it.

Best regards,

Žygimantas
by

Thank you for the swift response, after reading the forum more thoroughly I find that you don't provide the bootloader unless specifically requested.

Our company IT-policy is we need to use OpenWRT in any hardware which sadly then will result in we having to swap to a different manufacturer if it is no longer availble to install our own images. >100 units

What is the reason of forcing your stock firmware onto users and not being able to change to OpenWRT even though your companys firmware is built upon it?

I need a bootloader that allows using OpenWRT prebuilt images.

Regards,

P