subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
477 views 2 comments
by anonymous


I have a device with a FTP server installed on it (it's an embedded device, so I can set few parameters on it) and it's connected to the internet through a RUT955 with a public IP address. I successfully set the firewall so I can connect to the FTP server without any problem. Now I have to activate an FTP push functionality on the same device (the device has only to upload some files to a remote public FTP server), but I struggled to made it work; finally the only thing that worked was to disable the inbound port forwarding for the port 21 to the device (I don't understand why, but that's it). The problem now is to make to work the device FTP server again; I tried to change the port from 21 to another one, at first I changed the forwarding on the router then also the internal port of the device but in both cases I could only connect and login then every other commands failed with these errors:

ftp> ls
229 Entering Extended Passive Mode (|||33143|)
ftp: Can't connect to `XXX.XXX.XXX.XXX:33143': Connection refused
500 Illegal PORT command
ftp: Can't bind for data connection: Address already in use

(XXX.XXX.XXX.XXX is the public IP address)

I know there is a FTP passive connection tracking (FTP) which I previously enabled, this conntrack helper maybe works fine only with the standard port? Does anyone know what can I try to do to make the inbound and outbound FTP connections working at the same time?

Thank you

by anonymous

I think that the FTP doesn't work because the conntrack helper monitors only the ftp traffic on the standard port (21), I found a solution for this problem on another forum (for a generic linux server); they suggest to use these commands to enable the nf_conntrack_ftp on different ports than the 21:

  • rmmod nf_nat_ftp
  • rmmod nf_conntrack_ftp
  • modprobe nf_conntrack_ftp ports=21,1021
  • modprobe nf_nat_ftp
I tried but the second command failed, even if I disable the FTP passive connection tracking (FTP) before from the web interface.

1 Answer

0 votes
by anonymous

Have you managed to find a solution to this issue?
by anonymous
Hi, no I didn't find a solution, however the ftp push functionality was necessary only for a few days so we temporarily kept the ftp server off and enabled it again when we could turn off the outbound ftp.