10936 questions

13039 answers

20337 comments

27543 members

0 votes
92 views 4 comments
by

Hi . I'm using RUTX12 10 month on one single place with very good directional MIMO antenna.BTS visible , 3km distance- Mobile Signal is stable , RSSII , SNR never changed. Data speed over LTE vary , based on load of LTE users in my neighborhood. I'm rebooting RUTX12 on daily basisa night. Works well. 1 month before starts Modem disconnecting from mobile network. Modem alway disconnect /Mobile data disconnected (primary modem)/ and connect /Connected to T-Mobile CZ operator (primary modem) / again . It appears in varyous interval fro 1 - 10 mins.

The only change , maybe was new firmware RUTX_R_00.07.02.1 . I tried to upgrade to RUTX_R_00.07.02.2 . Didnt help , so I rollback to my current RUTX_R_00.07.02 , but disconnecting continues. 

I read Wiki questions about disconnecting , but it seems not helping me. Based on my research in system logs , there is problem with USB communication with Modem.


Pls. help me . I added my current Troubleshoot file.

by

EDIT: The update worked, in a way... Now the LEDs for reception is just blinking and I can't find the settings for the modems in the web interface. Says mob1s1... stopped. Please help! No Internet at all now.

Hi!

I have the same problem, running latest FW 07.02.4 and the same old modem firmware as 4kul but when I try to list available versions I get



root@Teltonika-RUTX12:~# modem_updater -D -g

[INFO] internet connection is working

[INFO] read: Connection reset by peer

Available versions:

umount: can't unmount /tmp/fwlist/: Invalid argument

root@Teltonika-RUTX12:~# 

I have tried to reset to factory settings and I'm using my iPhone as a hotspot for the RUTX12.

1 Answer

0 votes
by

Hello,

I would suggest to update firmware to at least 7.02.1 version.

Also, the modem version your device uses is quite old and should be updated. For this, you will need a different WAN source, either wired or wireless (Instructions on how to set up a router as a wireless client are provided here).

Below are the instructions on how to upgrade modem (not router) firmware.

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next, modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - since your router has two modems, should be 1-1.2 and 3-1. Try with 1-1.2 first, see if that helps. In case of an error you should be shown a correct IDs.
      •  <VERSION> - enter the latest firmware version from the list of the previously executed command, it should be EG06ELAR04A08M4G.

Repeat this procedure for the second modem. 

Keep in mind that frequent modem disconnects might also indicate failing hardware and you might need to return the device.

Best regards,

Žygimantas

by

Thank for help Žygimantas i upraded succefully first modem by cmd modem_updater -i 1-1.2 -v EG06ELAR04A08M4G . I will see if it helps.

Thanks LUMIR

by

I found thant affected modem is modem with ID 3-1. I Found it in /etc/board.json :-(

Now I tried to upgrade remotely over SSH over wan primary modem connection , but it didn't work.

modem_updater -i 3-1 -v EG06ELAR04A08M4G

[000.000]: Version: QFirehose_Linux_Android_V1.4.8

[000.001]: Builded: Aug 31 2021 22:20:08

[000.001]: P: /dev/bus/usb/003/006 idVendor=2c7c idProduct=0306

[000.001]: C: /dev/bus/usb/003/006 bNumInterfaces: 5

[000.001]: I: If#= 0 Alt= 0 #EPs= 2 Cls=ff Sub=ff Prot=ff

[000.001]: E: Ad=81 Atr=02 MxPS= 512 Ivl=0ms

[000.001]: E: Ad=01 Atr=02 MxPS= 512 Ivl=0ms

[000.001]: I: If#= 1 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00

[000.001]: E: Ad=83 Atr=03 MxPS= 10 Ivl=9ms

[000.001]: E: Ad=82 Atr=02 MxPS= 512 Ivl=0ms

[000.001]: E: Ad=02 Atr=02 MxPS= 512 Ivl=0ms

[000.001]: I: If#= 2 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00

[000.001]: E: Ad=85 Atr=03 MxPS= 10 Ivl=9ms

[000.001]: E: Ad=84 Atr=02 MxPS= 512 Ivl=0ms

[000.001]: E: Ad=03 Atr=02 MxPS= 512 Ivl=0ms

[000.001]: I: If#= 3 Alt= 0 #EPs= 3 Cls=ff Sub=00 Prot=00

[000.002]: E: Ad=87 Atr=03 MxPS= 10 Ivl=9ms

[000.002]: E: Ad=86 Atr=02 MxPS= 512 Ivl=0ms

[000.002]: E: Ad=04 Atr=02 MxPS= 512 Ivl=0ms

[000.002]: I: If#= 4 Alt= 0 #EPs= 3 Cls=ff Sub=ff Prot=ff

[000.002]: tmp=/sys/bus/usb/devices/usb3/../driver, driver=../../../../../../bus/platform/drivers/xhci-hcd

[000.002]: qusb_noblock_open port_name = /dev/ttyUSB4

[000.003]: old software version: EG06ELAR04A04M4G

[001.005]: poll_wait events=POLLIN msec=1000 timeout

[001.005]: switch to 'Emergency download mode'

[001.006]: successful, wait module reboot

After module reboot I see old firmware

root@rtx-app:~# gsmctl -V

EG06ELAR04A04M4G

by
The logs indicate an incomplete procedure. Are there any more messages? Are you sure the router has internet connectivity from wired or wireless source?