FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

13340 questions

15854 answers

25641 comments

50336 members

0 votes
117 views 0 comments
by

In some (all?) of our modems we observe that fail over does not work correctly if the interface is offline for a while. It stays offline, no matter what we do. Only changing the IP address in the failover configuration seems to help.

There is a bug in the handling of the configuration for mwan3: By default the track_ip is an option, not a list. This is probably caused by upgrading older modems to newer versions.

XXX:/etc/config# grep 8.8.8.8 mwan3
mwan3: list track_ip '8.8.8.8'
mwan3: option track_ip '8.8.8.8'
mwan3: option track_ip '8.8.8.8'

After clicking on '+' sign in the UI and then saving I observe:

XXX:/etc/config# grep 8.8.8.8 mwan3
mwan3: list track_ip '8.8.8.8'
mwan3: option track_ip '8.8.8.8'
mwan3: list track_ip '8.8.8.8'

mob2s1a1 failover state instantly goes to Online as well after this change in the config. A complete, incorrect, condition config section:

config condition
	option interface 'mob1s1a1'
	option track_method 'ping'
	option track_ip '8.8.8.8'                  <<<< Incorrect in 7.02.x
	option reliability '1'
	option count '1'
	option timeout '2'
	option up '3'
	option down '9'

Please make sure your upgrade of the firmware fixes this kind of problems for example by running an update script on first boot of the new firmware.

1 Answer

0 votes
by
Hi,

Thank you for notifying us regarding this issue.

I'll look into scripts which are executed during firmware upgrade, fixes will be most likely available with RUTOS 7.3 version.

Best regards,
Martynas
Best answer