FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
428 views 3 comments
by anonymous

We have about 30 Pcs Rut955 devices running. Some of them lose device-information during FW-Upgrade. They cannot be updated any more through web upgrade, further I cannot manually upgrade (beyond 6.x) because I don't know the Product Code. Why does this happen? How can I get and set those values correct again.
PS: I don't have physical access, because most of the devices are built in a vehicle.

root@Teltonika-RUTm:~# hexdump -C /dev/mtd1
00000000  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
00010000

1 Answer

0 votes
by anonymous

Hello,

How many devices have device data missing?

The restore procedure requires you to send us a serial number of the device and allow remote access to the device via SSH for one of Teltonika engineers.

As for the issue itself, it would be very helpful if you could get a troubleshoot file from the problematic devices and send it to me in a private message for analyzing. To get the file, connect to the device via SSH and execute the following command troubleshoot.sh. Once the script finishes, you will need to transfer the file to your PC. Instructions, how to download files from the router are provided here: https://wiki.teltonika-networks.com/view/Upload_%26_Download_Files_from_RutOS. The file is stored in /tmp directory.

Best regards,

Žygimantas

by anonymous

Because I have not immediately recognized the Problem, I don't know how many devices are affected. I think about 6 - 8.

All the devices have been updated online, a Product Code check should be done. I noticed the problem as I wanted to update them and there was no update available via WebUi, but I knew there must be one. So I cannot identify a single version-step. The last installed FW-Version is not the same on the devices.

The devices are installed in vehicles, which are distributed in Austria, Germany and Switzerland. I don't have physical access to most of the modems, so I cannot get the serial number If I don’t get it via console.

Also, most of the devices are in a private network without public IP. I sent a troubleshooting file from a device, but I cannot exact reconstruct the history of what I tried with this device.
Is there a way to get the Product code to know If the device is prepared for Vers 7?

by anonymous
Do you have a fix for this yet? I too have many devices like this in the field with 00's as a serial
by anonymous
Hello,

The fix is and not really. The way this works is that I would have to login to you local machine, restore the settings and then restore the router to factory settings, please reach out to me in private message to do this