FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12615 questions

14984 answers

23964 comments

46771 members

0 votes
137 views 6 comments
by

After succesfull configuration of two (different) RUT950 on two different PC, the sequnece Backup configuration - Restore configuration always refuse with message "wrong device type". But it is the same RUT950 still connected.

  • tried on Firefox and Chrome (recent version) and an two different machines (W10 recent version)
  • have two RUT types 'RUT950U02XXX' and 'RUT950002XXX' - same behaviour
  • rebooted the RUT950 ...
  • checked the downloaded configuration content - ok
  • It was working during the config sessions but now it does no more

Is there any special thing or block that refuses the upload of the same backup that was downloaded before?

Have seen another thread with same behaviour here backup-restoration-not-working but no solution.

1 Answer

0 votes
by

Hello,

I did not fully understand, are you trying to upload RUT950U02XXX backup to RUT950002XXX router? Or RUT950002XXX to RUT950002XXX?

What firmwares are you running on these devices?

by

Hi,

I trying to upload a just created backup to the same device for testing the backup-restore process.

The procedure is to create a configuration for one device batch/model e.g. the RUT950002XXX.

Procedure:

  • factory reset, firmware flash, no keeping any settings
  • configured all as needed (IP settings, firewall, mobile APN)
  • create a default confguration "System-Backup-Create Default Configuration"
  • backup the configuration to the connected laptop (wired connection) "System-Backup-Backup Configuration"
  • For testing log out or reboot (no differnece) - login again to the same device with the same laptop..
  • perform "System-Backup-Restore Configuartion" and select the just saved file xxx.tar.gz
  • it "uploads" then "verifying" then get the message "The selcted backup file is not compatible with this device,..."

Firmware: RUT9_R00.07.02.04 on both devices (new purchased some weeks ago).

Same behaviour on device A: RUT950U02XXX and on device B: RUT950002XXX.

What I have tried out meanwhile:

  • When I make a foctory reset to the device (trying to clear all except the firmware) then partially I can upload the backup, but it fails sometimes also here (did not found a certain pattern).
  • I observed the backuped archives form a factory resetted device with a full configured one, the differneces are only in the cfg files located in etc/config (found here a hint to conect via SSH WinSCP).

So main question is why a just generated backup file will fail the verification when reloaded back to the physically same device

by
Hello,

It should be possible to upload the backup on the same device. Could you check if maybe the backup file is more than 2mbs as that might be an issue?

Can you reproduce the same results with older FW versions?
by

The backup file size depends if i made  a "System-Backup-Create Default Configuration" or not and how often.

It seems growing with each step. Nevertheless it seems that it is only working when I reset he device completely.

Another effect shows. When I succefully uploaded a backup and change e.g. IP, the function  "System-Backup-Create Default Configuration" reports "An error occured" and afterwards the former default configuration is cleared in the WebUI ("-"). This is somehow unpredictable and lt looks like the OS can not create and write the tar.gz to its internal default config tar.gz file (only an assumption!)

Actual files i used are:

  • just set pwd after factory reset 183 kb
  • basic installation 746 kb
  • target installation 1.306 kb

Only tried recent firmware RUT9_R00.07.02.04.

by

I have now the RUT950002XXX upgraded to latest firmware RUT9_R00.07.02.06.

SIM card is inserted and router is fully function and online.

I set "keep settings".

After sucessful upgrade, I tried the same procedure:

  • system backup - backup configuration - download, saved as file
  • system backup - restore configuration - select the just saved file (size 1,7Mb) - sam failure message "The selcted backup file is not compatible with this device,..."

How to get that basic function working?

by

As a workaround, you can try to copy configuration files from the backup to the router using WinSCP as instructed in this page. The directory with the configuration is /etc/config

by
Thanks for the hint, yes we do it actually exactly like this.

The only isue is that we are afraid of changes of file accesrights during transfer.

As by the comment of @PaulisRug we will actually try out the latest legacy firmware for comparism.