FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12688 questions

15067 answers

24145 comments

47110 members

0 votes
186 views 2 comments
by
Hi,

I updated the firmware on my RUT360 to the latest version R_00.07.02.4 from R_00.07.02. The router now won't load the web UI after logon - it just says loading and constantly flashes the three mobile signal lights.

I've had a quick browse of the forum and tried some of the suggestions including the following:

1. Downgrade the firmware back to R_00.07.02 via SSH

2. Use the bootloader mode to flash the firmware back to a legacy version in this case R-00.02.06 - this allowed me to access the old web UI from which I re-flashed the firmware to R_00.07.02.4 with the keep settings button disabled.

Neither of these fixed the issue I still have a broken web ui and the three lights flash constantly.

When I run the logread command I get the following:

Sun Sep  4 19:08:00 2022 daemon.err mdcollectd: SQLite error: source and destination must be distinct
Sun Sep  4 19:08:00 2022 daemon.err mdcollectd: Error while doing database backup
Sun Sep  4 19:09:09 2022 kern.notice Authentication was successful from HTTP 172.16.1.107
Sun Sep  4 19:09:09 2022 daemon.err uhttpd[3105]: vuci: accepted login for admin from 172.16.1.107
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: /usr/bin/lua: /usr/lib/lua/ubus/ui.lua:653: attempt to index local 'boardInfo' (a nil value)
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: stack traceback:
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: /usr/lib/lua/ubus/ui.lua:653: in function 'generate_dynamic_routes'
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: /usr/lib/lua/ubus/ui.lua:749: in function 'get_menus'
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: /usr/lib/lua/ubus/ui.lua:955: in function </usr/lib/lua/ubus/ui.lua:949>
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: [C]: in function 'run'
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: /usr/sbin/vuci:98: in function 'main'
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: /usr/sbin/vuci:101: in main chunk
Sun Sep  4 19:09:09 2022 daemon.err vuci[7625]: [C]: ?

Is there anything else I can try?

Thanks

1 Answer

0 votes
by

Hello,

I would like you to provide more details about your device. Before attempting a firmware update, what was the device configuration? Have you made any mobile configuration changes, was remote access enabled, anything else other than default settings?

Could you connect to the device via command line or SSH and post the output of the following command: 

  • hexdump -C /dev/mtd1

Another thing you could do is to execute the command troubleshoot.sh in the command line. This would generate a log file in your device located in /tmp directory called similarly to troubleshoot.tar.gz. I would like you to copy this file using WinSCP to your PC (follow instructions provided here) and attach that file by editing your question.

Best regards,

by
Hi,

Thanks for your reply.

Here is the result of the hexdump command.

root@Teltonika-RUT360:~# hexdump -C /dev/mtd1
00000000  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
00010000

I'd not made many changes to the router's config. It was configured to reboot if it repeatedly failed to ping Google DNS, the LAN side settings had been updated to something appropriate for the network and the Wifi settings changed. I did initially enable RMS but this was allowed to lapse after the trial. I think the mobile config was just default.

I've taken a configuration backup using the sysupgrade-b command and attached this along with the results of the troubleshoot.sh script to the original post for you to look at.

Let me know if you need anything else.

Thanks.
by
Hello,

We will need to arrange a remote session via AnyDesk as one of the router's internal files got corrupted.

Could you send me router's serial number in a personal message?