subscribe to our Youtube


13387 questions

15914 answers


50510 members

0 votes
249 views 6 comments
Y have TRB140 Gateway.
Firmware is the latest: TRB1_R_00.07.02.6

I intend to use it as modem to connect to my local router (Bridge mode).

1) First attempts (early September 2022)

I was able to set it up, changing as little from factory default configuration as possible.

I first connected it directly to my Macbook High Sierra in NAT mode. it connected to internet provider and worked fine, providing internet access at good speed (30 MBPS). APN settings are correct.

Attaching it to the router's WAN port (using LAN DHCP) in Bridge mode, it connects correctly and I have access via router's wifi to the gateway in
But I have no internet access from my LAN.

I can ping from the router's interface to an IP address (, for example) but not using and an address (

I have tried using several DNS addresses, including and local ones, both setting them in the gateway as well as in the router.

Returning to direct connection, I could PING both ways from the gateway's WEBUI.

2)    New attempt (October 10, 2022)

With direct connection to notebook I can only ping to IP, but not to address.
It reports: "Error:ping: bad address ''"
Same from gateway's WEBUI as from notebook tool.
No internet access.

I attach the troubleshoot file.

1 Answer

0 votes

The troubleshoot file is not attached.

However, from what you have described, it seems like a DNS issue. Could you, if possible, modify network settings of your Macbook and specify, for example, the same google DNS server?

Best regards,
Sorry, I was sure that I had attached the file.

I agree that it should be a DNS issue, but I have tried almost everything on the Gateway.

I tried adding in my Mac profile, but same result.

Now I can't find how to attach the icons or buttons

Could you try the following:

Access the router via CLI/SSH (if you do not know how to do it, please check this page) and enter a set of the following commands and modifications:

  • cd /etc
  • vi resolv.conf

Press i to edit the file and add the following line:

  • nameserver

Press Esc, then enter :wq and press Enter to save. 

I did that.
By the way, CLI appears under System, not Services in my WEBUI.
On vi resolve.conf, following appears:
    search lan
    nameserver ::1
Don't know if 'nameserver ::1' is correct (semicolons, blank fields)!
Then command 'I'
Moved to blank line after 'nameserver ::1'
Inserted    nameserver
'esc' and ?:wq'
Checking with 'vi resolve.conf', following appears:
    search lan
    nameserver ::1
Should be OK.
Pinged IP OK
Pinged "Error:ping: bad address ''"
CLIed and vi resolv.conf to verify, but change wasn't saved.
File is the same as when started: Line 'nameserver' doesn't appear.
Deleted line 'nameserver ::1', suspecting that it might be incorrect.
Saved, checked again and it should be OK:
    search lan
Pinged again, but on address: "Error:ping: bad address ''"
CLIed and vi resolv.conf to verify, but again change wasn't saved.

Not being familiar with file resolv.conf I googled and found that supposedly it should only have 'nameserver' lines, and the first line would be incorrect, as well as the third; 'nameserver' should be a valid line.

But given that it isn't saving the file, I will wait for your comments before trying to clean it.

Given that in /etc the file is present as a link 'resolv.conf -> /tmp/resol', I checked the actual directory 'tmp' and there is:
    -rw-r--r--    1 root     root          47 Oct 16 20:15 resolv.conf
Also there is:
    drwxr-xr-x    2 root     root          60 Oct 16 20:15 resolv.conf.d
probably because I made a mistake using the vi editor. I think I should delete that file?
I must remark that the files date and time correspond to when I 'edited' it, but the file content is the original.

Looking further, I found out that following lines:  localhost loopback
::1        localhost

should be correct in hosts file (but with suffixes and no nameserver tag), but not in resolv.conf

I appreciate your support.
Further test:

Reset to factory default

Connected OK.

Pinged IP and address and both work now!

Putting the IP address of '' in the browser doesn't load the page. Strangely, after connection fails and stops, in the browser the IP has changed to the address ''.

Afterwards I set my Ethernet port's MAC address in the LAN's interface, but nothing changes. Still can ping in both ways, but I cannot browse.
So the TRB140 can ping both IPs and string addresses?

Most of the settings you mentioned above are default values and should not be edited.

The logs from the troubleshoot file provided are filled with records of DNS forwardings to both, your ISP and configured google DNS, the functionality seems to be working.

Could you test if you have a proper internet connectivity with the same SIM card in a smartphone? If so, could you check the APN settings the phone receives and compare them to the ones set in a TRB device?

Could you test the TRB device with another machine, for example, Windows based, and check if it is able to browse the internet.

Maybe your MAC has some firewall or other security measures enabled, could you disable them and test the connectivity?